linux: add 'Image' as the image name for aarch64
authorArnout Vandecappelle <arnout@mind.be>
Sun, 4 Oct 2015 16:28:15 +0000 (17:28 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 5 Oct 2015 14:01:32 +0000 (16:01 +0200)
On aarch64, the image name is always Image, so let's add support for
that.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/Config.in
linux/linux.mk

index bb4f86b7cd3e71c89f4a798ccaafcb8b320b7255..99c8a0ed54f8989d401afe35e4e9d8c505d4501b 100644 (file)
@@ -225,6 +225,10 @@ config BR2_LINUX_KERNEL_SIMPLEIMAGE
        select BR2_LINUX_KERNEL_DTS_SUPPORT
        select BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT
 
+config BR2_LINUX_KERNEL_IMAGE
+       bool "Image"
+       depends on BR2_aarch64
+
 config BR2_LINUX_KERNEL_LINUX_BIN
        bool "linux.bin"
        depends on BR2_microblaze
index c98459f330a5f781467d4d5d651f43be010cfa65..6c7ecfcc905e370c10cf5d118c0b0171efd35611 100644 (file)
@@ -111,6 +111,8 @@ else ifeq ($(BR2_LINUX_KERNEL_CUIMAGE),y)
 LINUX_IMAGE_NAME = cuImage.$(KERNEL_DTS_NAME)
 else ifeq ($(BR2_LINUX_KERNEL_SIMPLEIMAGE),y)
 LINUX_IMAGE_NAME = simpleImage.$(KERNEL_DTS_NAME)
+else ifeq ($(BR2_LINUX_KERNEL_IMAGE),y)
+LINUX_IMAGE_NAME = Image
 else ifeq ($(BR2_LINUX_KERNEL_LINUX_BIN),y)
 LINUX_IMAGE_NAME = linux.bin
 else ifeq ($(BR2_LINUX_KERNEL_VMLINUX_BIN),y)