autotargets: don't use install-strip
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Sep 2010 22:37:06 +0000 (00:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Sep 2010 13:24:39 +0000 (15:24 +0200)
Many packages using the AUTOTARGETS infrastructure do not support the
install-strip target. Moreover, we are already stripping all binary
files in the $(TARGET_DIR) anyway, so using install-strip is a bit
useless.

So, we use "make install" in all cases, and let Buildroot do the
stripping of the binaries if BR2_ENABLE_DEBUG is not set.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.autotools.in

index 1ccf44cd59911b72a84db1812c0a1b49b335b122..589079b6acbe91a0010fb671004230c25583fd17 100644 (file)
@@ -66,11 +66,7 @@ $(2)_AUTORECONF                      ?= NO
 $(2)_AUTORECONF_OPT            ?=
 $(2)_USE_CONFIG_CACHE           ?= $(if $(BR2_CONFIG_CACHE),YES,NO)
 $(2)_INSTALL_STAGING_OPT       ?= DESTDIR=$$(STAGING_DIR) install
-ifeq ($(BR2_ENABLE_DEBUG),y)
 $(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install
-else
-$(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install-strip
-endif
 $(2)_CLEAN_OPT                 ?= clean
 $(2)_UNINSTALL_STAGING_OPT     ?= DESTDIR=$$(STAGING_DIR) uninstall
 $(2)_UNINSTALL_TARGET_OPT      ?= DESTDIR=$$(TARGET_DIR)  uninstall