wireshark: add bcg729 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Nov 2018 10:10:28 +0000 (11:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 6 Nov 2018 23:14:04 +0000 (00:14 +0100)
- Optional dependency to bcg729 has been added with version 2.5.0 and
  https://github.com/wireshark/wireshark/commit/3e54cabf8193e6a8cd607b1671defb8b6800b53d
- Specify the path to found bcg729 as this is done for other options

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wireshark/wireshark.mk

index 39a306014919fa8e708543371bfe0a9bccfefe30..96cc15d1854d828f398ff7bca64632ebcbc6716b 100644 (file)
@@ -16,7 +16,6 @@ WIRESHARK_CONF_ENV = \
 
 WIRESHARK_CONF_OPTS = \
        --enable-static=no \
-       --without-bcg729 \
        --without-lz4 \
        --without-snappy \
        --with-libsmi=no \
@@ -52,6 +51,13 @@ ifeq ($(BR2_PACKAGE_WIRESHARK_GUI),)
 WIRESHARK_CONF_OPTS += --disable-wireshark
 endif
 
+ifeq ($(BR2_PACKAGE_BCG729),y)
+WIRESHARK_CONF_OPTS += --with-bcg729=$(STAGING_DIR)/usr
+WIRESHARK_DEPENDENCIES += bcg729
+else
+WIRESHARK_CONF_OPTS += --without-bcg729
+endif
+
 ifeq ($(BR2_PACKAGE_C_ARES),y)
 WIRESHARK_CONF_OPTS += --with-c-ares=$(STAGING_DIR)/usr
 WIRESHARK_DEPENDENCIES += c-ares