luaposix: bump to version 31
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 16 Sep 2013 16:52:55 +0000 (13:52 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 19 Sep 2013 19:31:53 +0000 (21:31 +0200)
Releases are no longer named 5.1.X, just the X portion remains now.

Fixes autoreconf issues with the automake bump, however since the patch
is no longer required that's not an issue now.

[Peter: now needs IPv6]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/luaposix/Config.in
package/luaposix/luaposix-remove-lua-header-check.patch [deleted file]
package/luaposix/luaposix.mk

index 412e07f138285576d6f59954435270242feb5740..58292829fa89235bed3d65a5efdd82bb140d0059 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_LUAPOSIX
        bool "luaposix"
+       depends on BR2_INET_IPV6
        help
          luaposix is a POSIX binding, including curses, for Lua 5.1
          and 5.2; Like most libraries it simply binds to C APIs on
@@ -9,3 +10,6 @@ config BR2_PACKAGE_LUAPOSIX
          APIs
 
          https://github.com/luaposix/luaposix
+
+comment "luaposix requires a toolchain with IPv6 support"
+       depends on !BR2_INET_IPV6
diff --git a/package/luaposix/luaposix-remove-lua-header-check.patch b/package/luaposix/luaposix-remove-lua-header-check.patch
deleted file mode 100644 (file)
index 7909b91..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-Checking the Lua version inside the headers requires compiling a small
-C program. However, autoconf will raise an error when attempting to do so
-while cross-compiling. Hence, this specific test is removed.
-
-Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
---- a/configure.ac     2013-06-20 07:23:27.943091833 +0300
-+++ b/configure.ac     2013-06-20 07:23:30.644441710 +0300
-@@ -105,7 +105,7 @@
- dnl Lua 5.1 or 5.2
- AX_PROG_LUA(501, 503)
- AX_LUA_HEADERS
--AX_LUA_HEADERS_VERSION(501, 503)
-+#AX_LUA_HEADERS_VERSION(501, 503)
- AC_SUBST(LUA)
- AC_SUBST(LUA_INCLUDE)
index 1d1ee6a746a625daa16523da2868bfb35f78dc6d..ff99127d8c7a61f2a1b1480604e5720f469c95fd 100644 (file)
@@ -4,12 +4,12 @@
 #
 ################################################################################
 
-LUAPOSIX_VERSION = 5.1.20
-LUAPOSIX_SITE = https://github.com/downloads/luaposix/luaposix
+LUAPOSIX_VERSION = 31
+LUAPOSIX_SITE = https://github.com/luaposix/luaposix/archive
+LUAPOSIX_SOURCE = release-v$(LUAPOSIX_VERSION).tar.gz
 LUAPOSIX_LICENSE = MIT
 LUAPOSIX_LICENSE_FILES = COPYING
 LUAPOSIX_DEPENDENCIES = lua host-lua
 LUAPOSIX_CONF_OPT = --libdir="/usr/lib/lua" --datarootdir="/usr/share/lua"
-LUAPOSIX_AUTORECONF = YES
 
 $(eval $(autotools-package))