Strip the perl binary
authorEric Andersen <andersen@codepoet.org>
Sat, 28 Jun 2003 03:13:23 +0000 (03:13 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 28 Jun 2003 03:13:23 +0000 (03:13 -0000)
make/perl.mk

index 2e1a92522d68384968a1285e6cce43a9781e46b1..f76a178d3e9a8858f3f417cc4eccd04f5ae10b86 100644 (file)
@@ -41,6 +41,10 @@ $(TARGET_DIR)/$(PERL_TARGET_BINARY): $(PERL_DIR)/$(PERL_BINARY)
        rm -f $(PERL_DIR)/install_me_here/usr/lib/perl/5.8.0/ExtUtils/MANIFEST.SKIP
        rm -f $(PERL_DIR)/install_me_here/usr/lib/perl/5.8.0/unicore/Makefile
        rm -rf $(TARGET_DIR)/usr/lib/perl
+       -$(STRIP) $(PERL_DIR)/install_me_here/usr/bin/a2p
+       -$(STRIP) $(PERL_DIR)/install_me_here/usr/bin/perl
+       rm -f $(PERL_DIR)/install_me_here/usr/bin/perl5.8.0
+       (cd $(PERL_DIR)/install_me_here/usr/bin; ln -sf perl perl5.8.0)
        cp -fa $(PERL_DIR)/install_me_here/* $(TARGET_DIR)/
        rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
                $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc