dbus: ensure dbus user is created
authorSamuel Martin <s.martin49@gmail.com>
Tue, 4 Feb 2014 11:46:19 +0000 (12:46 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 13 Feb 2014 22:18:41 +0000 (23:18 +0100)
Since we are changing the default dbus user, make sure this user is
consistently created.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dbus/dbus.mk

index 74e2041424632405737f7a6baa082f99f2de3817..e8b3da7a8647ac7ca3dba8acd7be373e59b2624a 100644 (file)
@@ -30,6 +30,10 @@ DBUS_CONF_OPT = --with-dbus-user=dbus \
                --with-system-socket=/var/run/dbus/system_bus_socket \
                --with-system-pid-file=/var/run/messagebus.pid
 
+define DBUS_USERS
+       dbus -1 dbus -1 * /var/run/dbus - dbus DBus messagebus user
+endef
+
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
 DBUS_CONF_OPT += LIBS='-lpthread'
 endif