efl/libecore: fix build with gcrypt
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Jan 2013 03:23:58 +0000 (03:23 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 1 Jan 2013 14:34:40 +0000 (15:34 +0100)
When building with gnutls, libecore also needs libgcrypt.

Fixes:

  http://autobuild.buildroot.org/results/4da454d6414cf8f4e638defae9b793fb46a0a072/build-end.log

While we're at it, also explicit the --enable-openssl /
--disable-openssl depending on whether openssl is available or not.

[Peter: only enable gnutls support when both gnutls and gcrypt are enabled]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libecore/libecore.mk

index 0220017dfd3403b061431985d757b5720bb9b679..dfc5750231f33c4dd47ae31b9d6a74de67e3bbd1 100644 (file)
@@ -36,10 +36,16 @@ endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBECORE_DEPENDENCIES += openssl
+LIBECORE_CONF_OPT += --enable-openssl
+else
+LIBECORE_CONF_OPT += --disable-openssl
 endif
 
-ifeq ($(BR2_PACKAGE_GNUTLS),y)
-LIBECORE_DEPENDENCIES += gnutls
+ifeq ($(BR2_PACKAGE_GNUTLS)$(BR2_PACKAGE_LIBGCRYPT),yy)
+LIBECORE_DEPENDENCIES += gnutls libgcrypt
+LIBECORE_CONF_OPT += --enable-gnutls --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+else
+LIBECORE_CONF_OPT += --disable-gnutls
 endif
 
 ifeq ($(BR2_PACKAGE_LIBCURL),y)