qt: build using old C++ standard
authorVlad Zakharov <vzakhar@synopsys.com>
Fri, 19 Aug 2016 16:18:43 +0000 (19:18 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 19 Aug 2016 21:07:42 +0000 (23:07 +0200)
'std::auto_ptr' is deprecated with gcc-6 but is used in qt4 code.
So we have to build using old C++ standard to prevent build failures.

qt4 is not being developed no more, so unfortunately we can't update
obsolete C++ code and have to add this workaround.

Fixes:
http://autobuild.buildroot.net/results/54172d55f39b2fcfa5b7fb4d4ee01566678babbc/
and also Qt build for ARC.

Signed-off-by: Vlad Zakharov <vzakhar@synopsys.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt/qt.mk

index 09b8dc291f8709cfbd4b10ac16c15a18b87cdc31..8c0ff7b034a2992fe34dc0cdc912e4e9118bc836 100644 (file)
@@ -41,6 +41,11 @@ QT_CFLAGS = $(TARGET_CFLAGS)
 QT_CXXFLAGS = $(TARGET_CXXFLAGS)
 QT_LDFLAGS = $(TARGET_LDFLAGS)
 
+# Qt WebKit build fails when gcc-6 is used for build, because
+# 'std::auto_ptr' is deprecated starting from gcc 6.x. So, we have to
+# use an older c++ standard to prevent build failure
+QT_CXXFLAGS += -std=gnu++98
+
 # Qt has some assembly function that are not present in thumb1 mode:
 # Error: selected processor does not support Thumb mode `swp r3,r7,[r4]'
 # so, we desactivate thumb mode