projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6f6b103
)
dbus: fix static linking issue with pthread
author
Romain Naour
<romain.naour@openwide.fr>
Sat, 5 Oct 2013 23:39:55 +0000
(
01:39
+0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Sun, 6 Oct 2013 10:55:29 +0000
(12:55 +0200)
-lpthread is missing when dbus is build with static lib
Fixes build failures:
http://autobuild.buildroot.net/results/
80a317e33afd1d5ba2f7dd9ecd89314b09b4b1fe
/
http://autobuild.buildroot.net/results/
2c3c040624652547bbeec363d7d6b03f2477ff00
/
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dbus/dbus.mk
patch
|
blob
|
history
diff --git
a/package/dbus/dbus.mk
b/package/dbus/dbus.mk
index d50f6309cba28ad7d3e352b55fff4dd544a84e2c..e2412478b5ae8496e0fcc77eb8ce46c2735243fa 100644
(file)
--- a/
package/dbus/dbus.mk
+++ b/
package/dbus/dbus.mk
@@
-30,6
+30,10
@@
DBUS_CONF_OPT = --with-dbus-user=dbus \
--with-system-socket=/var/run/dbus/system_bus_socket \
--with-system-pid-file=/var/run/messagebus.pid
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+DBUS_CONF_OPT += LIBS='-lpthread'
+endif
+
ifeq ($(BR2_microblaze),y)
# microblaze toolchain doesn't provide inotify_rm_* but does have sys/inotify.h
DBUS_CONF_OPT += --disable-inotify