flickcurl: adjust openssl dependency
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Jul 2014 21:26:53 +0000 (23:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Jul 2014 21:26:53 +0000 (23:26 +0200)
flickcurl does not specifically need openssl: it needs libcurl to have
crypto support to access https:// URLs. So, instead of depending on
openssl in FLICKCURL_DEPENDENCIES, this commit simply leaves it to the
Config.in file to select either OpenSSL, gnutls or libnss to make sure
libcurl will use one of these libraries.

Reported-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/flickcurl/Config.in
package/flickcurl/flickcurl.mk

index 7b917107ff1864f47c3b5fd271e4ad5d8aad921d..426ceecba15b6ad473715342d6b9fb6528b2c8b3 100644 (file)
@@ -2,6 +2,8 @@ config BR2_PACKAGE_FLICKCURL
        bool "flickcurl"
        select BR2_PACKAGE_LIBCURL
        select BR2_PACKAGE_LIBXML2
+       # Ensure that libcurl is built with crypto support, since
+       # flickcurl must access https:// URLs.
        select BR2_PACKAGE_OPENSSL if !(BR2_PACKAGE_GNUTLS || BR2_PACKAGE_LIBNSS)
        select BR2_PACKAGE_CA_CERTIFICATES # runtime
        help
index 67e88518f46b84f05f8fc1bfa6e0355fb439296f..43027453a6002e91b2058658aed074e140bbb60e 100644 (file)
@@ -11,7 +11,7 @@ FLICKCURL_LICENSE_FILES = COPYING COPYING.LIB LICENSE-2.0.txt LICENSE.html
 FLICKCURL_INSTALL_STAGING = YES
 FLICKCURL_CONFIG_SCRIPTS = flickcurl-config
 FLICKCURL_CONF_OPT = --without-curl-config --without-xml2-config --without-raptor
-FLICKCURL_DEPENDENCIES = libcurl libxml2 openssl host-pkgconf
+FLICKCURL_DEPENDENCIES = libcurl libxml2 host-pkgconf
 
 ifeq ($(BR2_PACKAGE_FLICKCURL_UTILS),)
 define FLICKCURL_REMOVE_UTILS