package/kmod: modinfo support of signature details
authorMatt Weber <matthew.weber@rockwellcollins.com>
Thu, 14 May 2020 18:28:06 +0000 (13:28 -0500)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 15 May 2020 20:24:19 +0000 (22:24 +0200)
Add conditional support to allow the module tools to use openssl
on target to inspect the signature of signed modules. If openssl
is not enabled the modinfo will show a hash algo as unknown.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Tested-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/kmod/kmod.mk

index e2dfea5c7be97648fb9bac55a515b4c4ecfaa504..0a79b2cf4d1599a4e687e6667255952ab84ca78f 100644 (file)
@@ -42,6 +42,13 @@ KMOD_DEPENDENCIES += xz
 KMOD_CONF_OPTS += --with-xz
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+KMOD_DEPENDENCIES += openssl
+KMOD_CONF_OPTS += --with-openssl
+else
+KMOD_CONF_OPTS += --without-openssl
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
 KMOD_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
 KMOD_CONF_OPTS += --enable-python