package/{mesa3d, mesa3d-headers}: bump version to 20.1.1
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 11 Jun 2020 06:05:38 +0000 (08:05 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 21 Jun 2020 07:21:05 +0000 (09:21 +0200)
Removed patches applied upstream:

- 0005-vc4_bufmgr-fix-time_t-printf.patch
  https://cgit.freedesktop.org/mesa/mesa/commit/?h=20.1&id=ad81207d00623cb2156ca0ecab39d0bcad5b28c9
- 0006-pan_bo.h-add-time.h-include-for-time_t.patch
  https://cgit.freedesktop.org/mesa/mesa/commit/?h=20.1&id=eedeee0094841c863e2f6ddd8bc2212d011e0e2f
- 0007-v3d_bufmgr-fix-time_t-printf.patch
  https://cgit.freedesktop.org/mesa/mesa/commit/?h=20.1&id=9f67806f141986c1d8310c5e0f1b2493434118d9

Renumbered remaining patches.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/mesa3d-headers/mesa3d-headers.mk
package/mesa3d/0003-c99_math-import-isinf-for-uclibc-based-toolchains.patch [new file with mode: 0644]
package/mesa3d/0004-c99_math-import-isinf-for-uclibc-based-toolchains.patch [deleted file]
package/mesa3d/0004-vc4-add-meson-option-to-disable-optional-neon-suppor.patch [new file with mode: 0644]
package/mesa3d/0005-vc4_bufmgr-fix-time_t-printf.patch [deleted file]
package/mesa3d/0006-pan_bo.h-add-time.h-include-for-time_t.patch [deleted file]
package/mesa3d/0007-v3d_bufmgr-fix-time_t-printf.patch [deleted file]
package/mesa3d/0007-vc4-add-meson-option-to-disable-optional-neon-suppor.patch [deleted file]
package/mesa3d/mesa3d.hash
package/mesa3d/mesa3d.mk

index 008c2c3cf44a2eaefb8617c4b9f4c633cc9a5b74..246abbd03385adef4c9643ee486703c6c38fdc40 100644 (file)
@@ -12,7 +12,7 @@ endif
 
 # Not possible to directly refer to mesa3d variables, because of
 # first/second expansion trickery...
-MESA3D_HEADERS_VERSION = 20.1.0
+MESA3D_HEADERS_VERSION = 20.1.1
 MESA3D_HEADERS_SOURCE = mesa-$(MESA3D_HEADERS_VERSION).tar.xz
 MESA3D_HEADERS_SITE = https://mesa.freedesktop.org/archive
 MESA3D_HEADERS_DL_SUBDIR = mesa3d
diff --git a/package/mesa3d/0003-c99_math-import-isinf-for-uclibc-based-toolchains.patch b/package/mesa3d/0003-c99_math-import-isinf-for-uclibc-based-toolchains.patch
new file mode 100644 (file)
index 0000000..5acbaa4
--- /dev/null
@@ -0,0 +1,30 @@
+From 705490763fcc052defa2d49a5c5200775cd12c54 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Wed, 4 Mar 2020 08:27:24 +0100
+Subject: [PATCH] c99_math: import isinf for uclibc based toolchains
+
+The same fix as for glibc >= 2.23 is needed for uclibc
+based toolchains.
+
+[Upstream suggested: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4042]
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ include/c99_math.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/c99_math.h b/include/c99_math.h
+index e906c26aa54..c8a73a2d2c7 100644
+--- a/include/c99_math.h
++++ b/include/c99_math.h
+@@ -190,7 +190,7 @@ fpclassify(double x)
+  * undefines those functions, which in glibc 2.23, are defined as macros rather
+  * than functions as in glibc 2.22.
+  */
+-#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23))
++#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23) || defined(__UCLIBC__))
+ #include <cmath>
+ using std::fpclassify;
+-- 
+2.25.1
+
diff --git a/package/mesa3d/0004-c99_math-import-isinf-for-uclibc-based-toolchains.patch b/package/mesa3d/0004-c99_math-import-isinf-for-uclibc-based-toolchains.patch
deleted file mode 100644 (file)
index 5acbaa4..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 705490763fcc052defa2d49a5c5200775cd12c54 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Wed, 4 Mar 2020 08:27:24 +0100
-Subject: [PATCH] c99_math: import isinf for uclibc based toolchains
-
-The same fix as for glibc >= 2.23 is needed for uclibc
-based toolchains.
-
-[Upstream suggested: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4042]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- include/c99_math.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/c99_math.h b/include/c99_math.h
-index e906c26aa54..c8a73a2d2c7 100644
---- a/include/c99_math.h
-+++ b/include/c99_math.h
-@@ -190,7 +190,7 @@ fpclassify(double x)
-  * undefines those functions, which in glibc 2.23, are defined as macros rather
-  * than functions as in glibc 2.22.
-  */
--#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23))
-+#if __cplusplus >= 201103L && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 23) || defined(__UCLIBC__))
- #include <cmath>
- using std::fpclassify;
--- 
-2.25.1
-
diff --git a/package/mesa3d/0004-vc4-add-meson-option-to-disable-optional-neon-suppor.patch b/package/mesa3d/0004-vc4-add-meson-option-to-disable-optional-neon-suppor.patch
new file mode 100644 (file)
index 0000000..138f145
--- /dev/null
@@ -0,0 +1,82 @@
+From e3b47c1b84964c62b3e1fa782f1ffa4be0ae62f9 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Mon, 9 Mar 2020 13:01:14 +0100
+Subject: [PATCH] vc4: add meson option to disable optional neon support
+
+Not all toolchains are able to compile the runtime
+optional vc4 neon support, so add an meson option
+to force disabling it at compile time.
+
+[Upstream: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4114]
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ meson_options.txt                    | 7 +++++++
+ src/gallium/drivers/vc4/meson.build  | 4 ++--
+ src/gallium/drivers/vc4/vc4_tiling.h | 4 ++--
+ 3 files changed, 11 insertions(+), 4 deletions(-)
+
+diff --git a/meson_options.txt b/meson_options.txt
+index a39596a6f19..0f6b6c62b55 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -117,6 +117,13 @@ option(
+   choices : ['auto', 'true', 'false'],
+   description : 'enable gallium va state tracker.',
+ )
++option(
++  'gallium-vc4-neon',
++  type : 'combo',
++  value : 'auto',
++  choices : ['auto', 'disabled'],
++  description : 'enable gallium vc4 optional neon support.',
++)
+ option(
+   'va-libs-path',
+   type : 'string',
+diff --git a/src/gallium/drivers/vc4/meson.build b/src/gallium/drivers/vc4/meson.build
+index 5ce5af5f6b4..e3f7d8d62ae 100644
+--- a/src/gallium/drivers/vc4/meson.build
++++ b/src/gallium/drivers/vc4/meson.build
+@@ -84,7 +84,7 @@ files_libvc4 = files(
+ vc4_c_args = []
+ libvc4_neon = []
+-if host_machine.cpu_family() == 'arm'
++if host_machine.cpu_family() == 'arm' and get_option('gallium-vc4-neon') != 'disabled'
+   libvc4_neon = static_library(
+     'vc4_neon',
+     'vc4_tiling_lt_neon.c',
+@@ -93,7 +93,7 @@ if host_machine.cpu_family() == 'arm'
+     ],
+     c_args : '-mfpu=neon',
+   )
+-  vc4_c_args += '-DUSE_ARM_ASM'
++  vc4_c_args += '-DVC4_TILING_LT_NEON'
+ endif
+ if dep_simpenrose.found()
+diff --git a/src/gallium/drivers/vc4/vc4_tiling.h b/src/gallium/drivers/vc4/vc4_tiling.h
+index 66767e7f1f8..7446f1c3d0c 100644
+--- a/src/gallium/drivers/vc4/vc4_tiling.h
++++ b/src/gallium/drivers/vc4/vc4_tiling.h
+@@ -89,7 +89,7 @@ vc4_load_lt_image(void *dst, uint32_t dst_stride,
+                   void *src, uint32_t src_stride,
+                   int cpp, const struct pipe_box *box)
+ {
+-#ifdef USE_ARM_ASM
++#ifdef VC4_TILING_LT_NEON
+         if (util_cpu_caps.has_neon) {
+                 vc4_load_lt_image_neon(dst, dst_stride, src, src_stride,
+                                        cpp, box);
+@@ -105,7 +105,7 @@ vc4_store_lt_image(void *dst, uint32_t dst_stride,
+                    void *src, uint32_t src_stride,
+                    int cpp, const struct pipe_box *box)
+ {
+-#ifdef USE_ARM_ASM
++#ifdef VC4_TILING_LT_NEON
+         if (util_cpu_caps.has_neon) {
+                 vc4_store_lt_image_neon(dst, dst_stride, src, src_stride,
+                                         cpp, box);
+-- 
+2.25.1
+
diff --git a/package/mesa3d/0005-vc4_bufmgr-fix-time_t-printf.patch b/package/mesa3d/0005-vc4_bufmgr-fix-time_t-printf.patch
deleted file mode 100644 (file)
index 56357e1..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 4ed48324b032857c95e6803409d5def9660d5b46 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Sun, 22 Mar 2020 11:42:35 +0100
-Subject: [PATCH] vc4_bufmgr: fix time_t printf
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes:
-
-  error: format ‘%ld’ expects argument of type ‘long int’, but argument 3 has type ‘time_t’ {aka ‘long long int’}
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- src/gallium/drivers/vc4/vc4_bufmgr.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/gallium/drivers/vc4/vc4_bufmgr.c b/src/gallium/drivers/vc4/vc4_bufmgr.c
-index f7ac1698ee3..a786e8ee939 100644
---- a/src/gallium/drivers/vc4/vc4_bufmgr.c
-+++ b/src/gallium/drivers/vc4/vc4_bufmgr.c
-@@ -100,7 +100,7 @@ vc4_bo_dump_stats(struct vc4_screen *screen)
-                 struct timespec time;
-                 clock_gettime(CLOCK_MONOTONIC, &time);
-                 fprintf(stderr, "  now:               %ld\n",
--                        time.tv_sec);
-+                        (long)time.tv_sec);
-         }
- }
--- 
-2.25.1
-
diff --git a/package/mesa3d/0006-pan_bo.h-add-time.h-include-for-time_t.patch b/package/mesa3d/0006-pan_bo.h-add-time.h-include-for-time_t.patch
deleted file mode 100644 (file)
index f90fb85..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From fc93d357efd207525a4ddaac609ab5a6bf469bcd Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Sun, 22 Mar 2020 11:48:31 +0100
-Subject: [PATCH] pan_bo.h: add time.h include for time_t
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes:
-
-  ../src/panfrost/encoder/pan_bo.h:93:9: error: unknown type name ‘time_t’
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
-[Bernd: rebased on 20.1]
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- src/panfrost/encoder/pan_bo.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/panfrost/encoder/pan_bo.h b/src/panfrost/encoder/pan_bo.h
-index 414c356b95c..6dda393095d 100644
---- a/src/panfrost/encoder/pan_bo.h
-+++ b/src/panfrost/encoder/pan_bo.h
-@@ -29,6 +29,7 @@
- #include <panfrost-misc.h>
- #include "util/list.h"
- #include "pan_device.h"
-+#include <time.h>
- /* Flags for allocated memory */
--- 
-2.25.1
-
diff --git a/package/mesa3d/0007-v3d_bufmgr-fix-time_t-printf.patch b/package/mesa3d/0007-v3d_bufmgr-fix-time_t-printf.patch
deleted file mode 100644 (file)
index f8031c2..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From c4984ce2b7d3bd7129ddb02e4e423bf00498607a Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Sun, 22 Mar 2020 13:03:00 +0100
-Subject: [PATCH] v3d_bufmgr: fix time_t printf
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes:
-
-  error: format ‘%ld’ expects argument of type ‘long int’, but argument 3 has type ‘time_t’ {aka ‘long long int’}
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- src/gallium/drivers/v3d/v3d_bufmgr.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/gallium/drivers/v3d/v3d_bufmgr.c b/src/gallium/drivers/v3d/v3d_bufmgr.c
-index 50e4081dafd..31a08036b38 100644
---- a/src/gallium/drivers/v3d/v3d_bufmgr.c
-+++ b/src/gallium/drivers/v3d/v3d_bufmgr.c
-@@ -81,7 +81,7 @@ v3d_bo_dump_stats(struct v3d_screen *screen)
-                 struct timespec time;
-                 clock_gettime(CLOCK_MONOTONIC, &time);
-                 fprintf(stderr, "  now:               %ld\n",
--                        time.tv_sec);
-+                        (long)time.tv_sec);
-         }
- }
--- 
-2.25.1
-
diff --git a/package/mesa3d/0007-vc4-add-meson-option-to-disable-optional-neon-suppor.patch b/package/mesa3d/0007-vc4-add-meson-option-to-disable-optional-neon-suppor.patch
deleted file mode 100644 (file)
index 138f145..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-From e3b47c1b84964c62b3e1fa782f1ffa4be0ae62f9 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Mon, 9 Mar 2020 13:01:14 +0100
-Subject: [PATCH] vc4: add meson option to disable optional neon support
-
-Not all toolchains are able to compile the runtime
-optional vc4 neon support, so add an meson option
-to force disabling it at compile time.
-
-[Upstream: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4114]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- meson_options.txt                    | 7 +++++++
- src/gallium/drivers/vc4/meson.build  | 4 ++--
- src/gallium/drivers/vc4/vc4_tiling.h | 4 ++--
- 3 files changed, 11 insertions(+), 4 deletions(-)
-
-diff --git a/meson_options.txt b/meson_options.txt
-index a39596a6f19..0f6b6c62b55 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -117,6 +117,13 @@ option(
-   choices : ['auto', 'true', 'false'],
-   description : 'enable gallium va state tracker.',
- )
-+option(
-+  'gallium-vc4-neon',
-+  type : 'combo',
-+  value : 'auto',
-+  choices : ['auto', 'disabled'],
-+  description : 'enable gallium vc4 optional neon support.',
-+)
- option(
-   'va-libs-path',
-   type : 'string',
-diff --git a/src/gallium/drivers/vc4/meson.build b/src/gallium/drivers/vc4/meson.build
-index 5ce5af5f6b4..e3f7d8d62ae 100644
---- a/src/gallium/drivers/vc4/meson.build
-+++ b/src/gallium/drivers/vc4/meson.build
-@@ -84,7 +84,7 @@ files_libvc4 = files(
- vc4_c_args = []
- libvc4_neon = []
--if host_machine.cpu_family() == 'arm'
-+if host_machine.cpu_family() == 'arm' and get_option('gallium-vc4-neon') != 'disabled'
-   libvc4_neon = static_library(
-     'vc4_neon',
-     'vc4_tiling_lt_neon.c',
-@@ -93,7 +93,7 @@ if host_machine.cpu_family() == 'arm'
-     ],
-     c_args : '-mfpu=neon',
-   )
--  vc4_c_args += '-DUSE_ARM_ASM'
-+  vc4_c_args += '-DVC4_TILING_LT_NEON'
- endif
- if dep_simpenrose.found()
-diff --git a/src/gallium/drivers/vc4/vc4_tiling.h b/src/gallium/drivers/vc4/vc4_tiling.h
-index 66767e7f1f8..7446f1c3d0c 100644
---- a/src/gallium/drivers/vc4/vc4_tiling.h
-+++ b/src/gallium/drivers/vc4/vc4_tiling.h
-@@ -89,7 +89,7 @@ vc4_load_lt_image(void *dst, uint32_t dst_stride,
-                   void *src, uint32_t src_stride,
-                   int cpp, const struct pipe_box *box)
- {
--#ifdef USE_ARM_ASM
-+#ifdef VC4_TILING_LT_NEON
-         if (util_cpu_caps.has_neon) {
-                 vc4_load_lt_image_neon(dst, dst_stride, src, src_stride,
-                                        cpp, box);
-@@ -105,7 +105,7 @@ vc4_store_lt_image(void *dst, uint32_t dst_stride,
-                    void *src, uint32_t src_stride,
-                    int cpp, const struct pipe_box *box)
- {
--#ifdef USE_ARM_ASM
-+#ifdef VC4_TILING_LT_NEON
-         if (util_cpu_caps.has_neon) {
-                 vc4_store_lt_image_neon(dst, dst_stride, src, src_stride,
-                                         cpp, box);
--- 
-2.25.1
-
index c8eda7b2baf4efce642c2c3fecefa131a34e95ef..73dcf6ad81fc6432fc7761f980f3f4c6525f25e5 100644 (file)
@@ -1,6 +1,6 @@
-# From https://lists.freedesktop.org/archives/mesa-announce/2020-May/000585.html
-sha256  2109055d7660514fc4c1bcd861bcba9db00c026119ae222720111732dba27c83  mesa-20.1.0.tar.xz
-sha512  f49230d18febe1bfd7c6282ab95fc244530f5cef56df0f804d8bece8a70bafcb445b8b83df96ad1b4c5af022c4e39a71f19a8f7e47b1fb09ada2b1a1317ff3be  mesa-20.1.0.tar.xz
+# From https://lists.freedesktop.org/archives/mesa-announce/2020-June/000587.html
+sha256  3ea6e46ea7881c656f7b4724639eaa4672d4e0e0b70869651e8f955ebae3d476  mesa-20.1.1.tar.xz
+sha512  a8ae02915305488e5e0d8c104da73df1cdd61ab0b5c5d27a6851c418d25a2c9beeea9cddf93a341afa63cec52d356fe68b194c8c36e78c26f66fa884fc27f147  mesa-20.1.1.tar.xz
 
 # License
 sha256  1ddae7da415352a5b5360ff3a9d7ecf23ba81408f62eeecce0011f32e3ef9da6  docs/license.html
index 59d96fe7c2624b4da70a99215f044cb021df3c9c..4e083979ccddf5fd0e871502a62aaca3ba44113b 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 # When updating the version, please also update mesa3d-headers
-MESA3D_VERSION = 20.1.0
+MESA3D_VERSION = 20.1.1
 MESA3D_SOURCE = mesa-$(MESA3D_VERSION).tar.xz
 MESA3D_SITE = https://mesa.freedesktop.org/archive
 MESA3D_LICENSE = MIT, SGI, Khronos