package/pcsc-lite: drop unneeded first patch
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 18 May 2019 21:43:47 +0000 (23:43 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 20 May 2019 09:06:02 +0000 (11:06 +0200)
This patch is not needed as static build has been disabled since
commit ad8c327053f3736881e1ef6d7b394b3a500ed8fa

Moreover, pthread dependency should be correctly retrieved from
libusb-1.0.pc

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pcsc-lite/0001-Add-disable-documentation-option.patch [new file with mode: 0644]
package/pcsc-lite/0001-pthread-needed-for-libusb.patch [deleted file]
package/pcsc-lite/0002-Add-disable-documentation-option.patch [deleted file]

diff --git a/package/pcsc-lite/0001-Add-disable-documentation-option.patch b/package/pcsc-lite/0001-Add-disable-documentation-option.patch
new file mode 100644 (file)
index 0000000..6a083f5
--- /dev/null
@@ -0,0 +1,63 @@
+From 77ac8fcb78e3085577cd4eb5c4ac7746a5444f13 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Fri, 17 May 2019 15:48:35 +0200
+Subject: [PATCH] Add --disable-documentation option
+
+This option allows the user to disable man pages which can be useful if
+podman is not available
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://github.com/LudovicRousseau/PCSC/pull/60]
+---
+ configure.ac        | 7 +++++++
+ src/spy/Makefile.am | 2 ++
+ 2 files changed, 9 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 0fa5168..7d20c6e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -144,6 +144,12 @@ esac
+ AC_DEFINE_UNQUOTED(PCSC_ARCH, "$PCSC_ARCH", [PC/SC target architecture])
+ PCSCLITE_FEATURES="${PCSCLITE_FEATURES} $PCSC_ARCH $host"
++# --disable-documentation
++AC_ARG_ENABLE(documentation,
++      AS_HELP_STRING([--disable-documentation],[do not build documentation]),
++      [ enable_doc="${enableval}" ], [ enable_doc="yes" ] )
++AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" != "no")
++
+ # See if socket() is found from libsocket
+ AC_CHECK_LIB(socket, socket, [LIBS="$LIBS -lsocket"])
+@@ -446,6 +452,7 @@ use libsystemd:         ${use_libsystemd}
+ systemd unit directory: ${with_systemdsystemunitdir}
+ serial config dir.:     ${confdir_exp}
+ filter:                 ${use_filter}
++documentation:          ${enable_doc}
+ PCSCLITE_FEATURES:      ${PCSCLITE_FEATURES}
+diff --git a/src/spy/Makefile.am b/src/spy/Makefile.am
+index 3c3daee..0a83371 100644
+--- a/src/spy/Makefile.am
++++ b/src/spy/Makefile.am
+@@ -6,6 +6,7 @@ dist_bin_SCRIPTS = pcsc-spy
+ libpcscspy_la_SOURCES = \
+       libpcscspy.c
++if ENABLE_DOC
+ man_MANS = pcsc-spy.1
+ pcsc-spy.1: pcsc-spy.pod
+@@ -13,6 +14,7 @@ pcsc-spy.1: pcsc-spy.pod
+               --center="PC/SC lite" \
+               --release="$(PACKAGE_NAME) $(PACKAGE_VERSION)" \
+               $(srcdir)/pcsc-spy.pod > $@
++endif
+ EXTRA_DIST = install_spy.sh uninstall_spy.sh pcsc-spy.pod
+ CLEANFILES = pcsc-spy.1
+-- 
+2.20.1
+
diff --git a/package/pcsc-lite/0001-pthread-needed-for-libusb.patch b/package/pcsc-lite/0001-pthread-needed-for-libusb.patch
deleted file mode 100644 (file)
index acb777a..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-configure.ac: explicitly add pthread cflags/libs in the libusb test
-
-If libusb-config does not exist, LIBUSB_CFLAGS and PTHREAD_CFLAGS will be
-empty, and the test for libusb will be performed without additional flags.
-However, when libusb needs threads, some extra flags are needed (depending
-on the platform), like -pthreads, -lpthread, etc. Without these flags, the
-test for libusb_init() will fail to link correctly, and pcsc-lite will fail
-detecting libusb.
-
-Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
-
-Upstream-status: will be submitted
-
----
-
-diff --git a/configure.ac b/configure.ac
---- a/configure.ac
-+++ b/configure.ac
-@@ -254,8 +254,8 @@ if test "x$use_libusb" != xno ; then
-       saved_CPPFLAGS="$CPPFLAGS"
-       saved_LIBS="$LIBS"
--      CPPFLAGS="$CPPFLAGS $LIBUSB_CFLAGS"
--      LIBS="$LDFLAGS $LIBUSB_LIBS"
-+      CPPFLAGS="$CPPFLAGS $LIBUSB_CFLAGS $PTHREAD_CFLAGS"
-+      LIBS="$LDFLAGS $LIBUSB_LIBS $PTHREAD_LIBS"
-       AC_CHECK_HEADERS(libusb.h, [],
-               [ AC_MSG_ERROR([libusb.h not found, use ./configure LIBUSB_CFLAGS=...]) ])
diff --git a/package/pcsc-lite/0002-Add-disable-documentation-option.patch b/package/pcsc-lite/0002-Add-disable-documentation-option.patch
deleted file mode 100644 (file)
index 6a083f5..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-From 77ac8fcb78e3085577cd4eb5c4ac7746a5444f13 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Fri, 17 May 2019 15:48:35 +0200
-Subject: [PATCH] Add --disable-documentation option
-
-This option allows the user to disable man pages which can be useful if
-podman is not available
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/LudovicRousseau/PCSC/pull/60]
----
- configure.ac        | 7 +++++++
- src/spy/Makefile.am | 2 ++
- 2 files changed, 9 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 0fa5168..7d20c6e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -144,6 +144,12 @@ esac
- AC_DEFINE_UNQUOTED(PCSC_ARCH, "$PCSC_ARCH", [PC/SC target architecture])
- PCSCLITE_FEATURES="${PCSCLITE_FEATURES} $PCSC_ARCH $host"
-+# --disable-documentation
-+AC_ARG_ENABLE(documentation,
-+      AS_HELP_STRING([--disable-documentation],[do not build documentation]),
-+      [ enable_doc="${enableval}" ], [ enable_doc="yes" ] )
-+AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" != "no")
-+
- # See if socket() is found from libsocket
- AC_CHECK_LIB(socket, socket, [LIBS="$LIBS -lsocket"])
-@@ -446,6 +452,7 @@ use libsystemd:         ${use_libsystemd}
- systemd unit directory: ${with_systemdsystemunitdir}
- serial config dir.:     ${confdir_exp}
- filter:                 ${use_filter}
-+documentation:          ${enable_doc}
- PCSCLITE_FEATURES:      ${PCSCLITE_FEATURES}
-diff --git a/src/spy/Makefile.am b/src/spy/Makefile.am
-index 3c3daee..0a83371 100644
---- a/src/spy/Makefile.am
-+++ b/src/spy/Makefile.am
-@@ -6,6 +6,7 @@ dist_bin_SCRIPTS = pcsc-spy
- libpcscspy_la_SOURCES = \
-       libpcscspy.c
-+if ENABLE_DOC
- man_MANS = pcsc-spy.1
- pcsc-spy.1: pcsc-spy.pod
-@@ -13,6 +14,7 @@ pcsc-spy.1: pcsc-spy.pod
-               --center="PC/SC lite" \
-               --release="$(PACKAGE_NAME) $(PACKAGE_VERSION)" \
-               $(srcdir)/pcsc-spy.pod > $@
-+endif
- EXTRA_DIST = install_spy.sh uninstall_spy.sh pcsc-spy.pod
- CLEANFILES = pcsc-spy.1
--- 
-2.20.1
-