postgresql: add optional dependency on libxml2
authorThomas Ehrhardt <TEhrhardt@innovaphone.com>
Fri, 27 Jul 2018 07:41:25 +0000 (07:41 +0000)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 28 Jul 2018 14:06:07 +0000 (16:06 +0200)
The postgresql package is now built with --with-libxml if
BR2_PACKAGE_LIBXML2 is selected to allow the use of XML functions in
postgresql.

Signed-off-by: Daniel Deterding <dde@innovaphone.com>
Signed-off-by: Thomas Ehrhardt <tehrhardt@innovaphone.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/postgresql/postgresql.mk

index 94b3e60e593d94f8b052c753b0867091c7f5bd2f..0940873686e974654b6db16732d9f0c55a1b4d1b 100644 (file)
@@ -70,6 +70,14 @@ else
 POSTGRESQL_CONF_OPTS += --without-ldap
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+POSTGRESQL_DEPENDENCIES += libxml2
+POSTGRESQL_CONF_OPTS += --with-libxml
+POSTGRESQL_CONF_ENV += XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
+else
+POSTGRESQL_CONF_OPTS += --without-libxml
+endif
+
 define POSTGRESQL_USERS
        postgres -1 postgres -1 * /var/lib/pgsql /bin/sh - PostgreSQL Server
 endef