package/paho-mqtt-c: disable tests and cpack docs
authorDanomi Manchego <danomimanchego123@gmail.com>
Sat, 25 Apr 2020 19:56:08 +0000 (15:56 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Apr 2020 20:18:55 +0000 (22:18 +0200)
paho-mqtt-c by default enables the building of test materials and
install of CPack documentation:

PAHO_ENABLE_TESTING - "Build tests and run"
PAHO_ENABLE_CPACK - "Enable CPack"

Let's disable these to save a couple megabytes and time.  This is
in keeping with the generic settings in pkg-cmake.mk.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/paho-mqtt-c/paho-mqtt-c.mk

index 7cace9a607ae4e240235af57877362711e3d871d..6a6b5f3d64c27d081b5eca6017836b30deb3a772 100644 (file)
@@ -10,6 +10,10 @@ PAHO_MQTT_C_LICENSE = EPL-2.0 or BSD-3-Clause
 PAHO_MQTT_C_LICENSE_FILES = epl-v20 edl-v10 LICENSE
 PAHO_MQTT_C_INSTALL_STAGING = YES
 
+PAHO_MQTT_C_CONF_OPTS = \
+       -DPAHO_ENABLE_TESTING=FALSE \
+       -DPAHO_ENABLE_CPACK=FALSE
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 PAHO_MQTT_C_DEPENDENCIES += openssl
 PAHO_MQTT_C_CONF_OPTS += -DPAHO_WITH_SSL=TRUE