package/xserver_xorg-server: not all versions need all dependencies
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 21 Apr 2015 17:04:40 +0000 (19:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Apr 2015 20:24:10 +0000 (22:24 +0200)
Support for the Present protocol has been added to, and is mandatory
since version 1.15.

As we're on the verge of adding 1.14.7, we need to make Present a
version-specific dependency.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index c578528021b32285d2bebbb7723ac30831ba03df..2fccef686a552895b71e5f73996b955afc25b517 100644 (file)
@@ -35,7 +35,6 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
        select BR2_PACKAGE_XPROTO_GLPROTO
        select BR2_PACKAGE_XPROTO_INPUTPROTO
        select BR2_PACKAGE_XPROTO_KBPROTO
-       select BR2_PACKAGE_XPROTO_PRESENTPROTO
        select BR2_PACKAGE_XPROTO_RANDRPROTO
        select BR2_PACKAGE_XPROTO_RENDERPROTO
        select BR2_PACKAGE_XPROTO_RESOURCEPROTO
@@ -69,6 +68,7 @@ choice
 config BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_17
        bool "1.17.1"
        select BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_19
+       select BR2_PACKAGE_XPROTO_PRESENTPROTO
 
 endchoice
 
index d08197de13c8f603ed8559435522cb47a14ed08d..79d663c6ccae0231cee57caf4fb49a6e15737c51 100644 (file)
@@ -38,7 +38,6 @@ XSERVER_XORG_SERVER_DEPENDENCIES =    \
        xproto_glproto                  \
        xproto_inputproto               \
        xproto_kbproto                  \
-       xproto_presentproto             \
        xproto_randrproto               \
        xproto_renderproto              \
        xproto_resourceproto            \
@@ -75,6 +74,12 @@ XSERVER_XORG_SERVER_CONF_OPTS += \
        --disable-systemd-logind
 endif
 
+# Present protocol only required for xserver 1.15+, but does not matter if
+# enabled for older versions as they don't use it (not even optionally).
+ifeq ($(BR2_PACKAGE_XPROTO_PRESENTPROTO),y)
+XSERVER_XORG_SERVER_DEPENDENCIES += xproto_presentproto
+endif
+
 ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_MODULAR),y)
 XSERVER_XORG_SERVER_CONF_OPTS += --enable-xorg
 XSERVER_XORG_SERVER_DEPENDENCIES += libpciaccess