package/kodi-visualisation-goom: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 22:09:06 +0000 (23:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Feb 2016 22:19:29 +0000 (23:19 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/kodi-visualisation-goom/0001-cross-compile.patch [new file with mode: 0644]
package/kodi-visualisation-goom/Config.in [new file with mode: 0644]
package/kodi-visualisation-goom/kodi-visualisation-goom.hash [new file with mode: 0644]
package/kodi-visualisation-goom/kodi-visualisation-goom.mk [new file with mode: 0644]
package/kodi/Config.in
package/kodi/kodi.mk

index 53baa84f5681bcaf5ce111c34c735b944141eae8..3def8a122415a848c01b02a4e29b8209580c5119 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.05"
 
+config BR2_PACKAGE_KODI_GOOM
+       bool "Goom support in Kodi was moved to an addon"
+       select BR2_LEGACY
+       select BR2_PACKAGE_KODI_VISUALISATION_GOOM
+       help
+         Goom support in Kodi was moved to an addon
+
 config BR2_PACKAGE_SYSTEMD_ALL_EXTRAS
        bool "systemd all extras option has been removed"
        select BR2_LEGACY
diff --git a/package/kodi-visualisation-goom/0001-cross-compile.patch b/package/kodi-visualisation-goom/0001-cross-compile.patch
new file mode 100644 (file)
index 0000000..8dd0fe9
--- /dev/null
@@ -0,0 +1,32 @@
+Fix cross-compilation
+
+Use the cross-compiler and not the host version.
+
+Patch sent upstream:
+https://github.com/notspiff/visualization.goom/pull/4
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+diff -uNr visualization.goom-fb5933ba5b2143d055cc7749dc60a82f6002b305.org/CMakeLists.txt visualization.goom-fb5933ba5b2143d055cc7749dc60a82f6002b305/CMakeLists.txt
+--- visualization.goom-fb5933ba5b2143d055cc7749dc60a82f6002b305.org/CMakeLists.txt     2014-10-31 11:34:21.000000000 +0100
++++ visualization.goom-fb5933ba5b2143d055cc7749dc60a82f6002b305/CMakeLists.txt 2015-07-19 19:49:43.340054342 +0200
+@@ -13,6 +13,10 @@
+                     ${KODI_INCLUDE_DIR}
+                     ${PROJECT_SOURCE_DIR}/lib/goom2k4-0/src)
++get_filename_component( COMPILER_FILENAME "${CMAKE_C_COMPILER}" NAME )
++string( REGEX REPLACE "-[^-]+$" ""
++        TOOLCHAIN_NAME "${COMPILER_FILENAME}" )
++
+ include(ExternalProject)
+ set(update_command "")
+ if(BOOTSTRAP_IN_TREE OR NOT DEFINED BOOTSTRAP_IN_TREE)
+@@ -20,7 +24,7 @@
+ endif()
+ externalproject_add(libgoom SOURCE_DIR ${PROJECT_SOURCE_DIR}/lib/goom2k4-0
+                     "${update_command}"
+-                    CONFIGURE_COMMAND ${PROJECT_SOURCE_DIR}/lib/goom2k4-0/configure --disable-shared --enable-static --with-pic --prefix=<INSTALL_DIR>
++                    CONFIGURE_COMMAND ${PROJECT_SOURCE_DIR}/lib/goom2k4-0/configure --disable-shared --enable-static --with-pic --prefix=<INSTALL_DIR> --host=${TOOLCHAIN_NAME}
+                     BUILD_COMMAND ${MAKE}
+                     INSTALL_COMMAND "")
diff --git a/package/kodi-visualisation-goom/Config.in b/package/kodi-visualisation-goom/Config.in
new file mode 100644 (file)
index 0000000..c5fa982
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_KODI_VISUALISATION_GOOM
+       bool "kodi-visualisation-goom"
+       depends on BR2_PACKAGE_KODI_GL
+       help
+         GOOM visualiser for Kodi
+
+         https://github.com/notspiff/visualization.goom
+
+comment "kodi-visualization-goom needs an OpenGL backend"
+       depends on !BR2_PACKAGE_KODI_GL
diff --git a/package/kodi-visualisation-goom/kodi-visualisation-goom.hash b/package/kodi-visualisation-goom/kodi-visualisation-goom.hash
new file mode 100644 (file)
index 0000000..8507c65
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 66a71a5c5a1c0016d7020fcc9941634ee465dab14644cdc96023ce0a28408338 kodi-visualisation-goom-16747b7dba9cbdcfdc8df44e849eaf09450fc86f.tar.gz
diff --git a/package/kodi-visualisation-goom/kodi-visualisation-goom.mk b/package/kodi-visualisation-goom/kodi-visualisation-goom.mk
new file mode 100644 (file)
index 0000000..89f2bab
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# kodi-visualisation-goom
+#
+################################################################################
+
+KODI_VISUALISATION_GOOM_VERSION = 16747b7dba9cbdcfdc8df44e849eaf09450fc86f
+KODI_VISUALISATION_GOOM_SITE = $(call github,notspiff,visualization.goom,$(KODI_VISUALISATION_GOOM_VERSION))
+KODI_VISUALISATION_GOOM_LICENSE = GPLv2+
+KODI_VISUALISATION_GOOM_LICENSE_FILES = src/Main.cpp
+
+KODI_VISUALISATION_GOOM_DEPENDENCIES = kodi
+
+$(eval $(cmake-package))
index 7d288820268ddeff808def570e9e5f4bd4fb8076..dcddade60da39388c5a50efbbfa02350b52c2673 100644 (file)
@@ -136,15 +136,6 @@ config BR2_PACKAGE_KODI_LIBBLURAY
 comment "libbluray support needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
 
-config BR2_PACKAGE_KODI_GOOM
-       bool "goom screensaver"
-       depends on BR2_PACKAGE_KODI_GL
-       help
-         Enable goom screensaver
-
-comment "goom needs an OpenGL backend"
-       depends on !BR2_PACKAGE_KODI_GL
-
 config BR2_PACKAGE_KODI_RSXS
        bool "rsxs screensaver"
        depends on BR2_PACKAGE_KODI_GL
@@ -308,6 +299,7 @@ menu "Screensavers"
 endmenu
 
 menu "Visualisations"
+       source "package/kodi-visualisation-goom/Config.in"
        source "package/kodi-visualisation-shadertoy/Config.in"
        source "package/kodi-visualisation-spectrum/Config.in"
        source "package/kodi-visualisation-waveforhue/Config.in"
index bf3aa7a06444f69de3af2103617442cee14a0f17..94e59e7a954cbb9937ea88547a943d2f7f0a74ed 100644 (file)
@@ -30,6 +30,7 @@ KODI_CONF_ENV = \
 
 KODI_CONF_OPTS +=  \
        --with-ffmpeg=shared \
+       --disable-goom \
        --disable-joystick \
        --disable-openmax \
        --disable-projectm \
@@ -116,12 +117,6 @@ KODI_CONF_OPTS += --disable-gles
 endif
 endif
 
-ifeq ($(BR2_PACKAGE_KODI_GOOM),y)
-KODI_CONF_OPTS += --enable-goom
-else
-KODI_CONF_OPTS += --disable-goom
-endif
-
 ifeq ($(BR2_PACKAGE_KODI_LIBUSB),y)
 KODI_DEPENDENCIES += libusb-compat
 KODI_CONF_OPTS += --enable-libusb