libxmlrpc: rename patches to the new convention
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 13:47:15 +0000 (14:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 16:21:18 +0000 (17:21 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/libxmlrpc/0001-fix-gennmtab-build.patch [new file with mode: 0644]
package/libxmlrpc/0002-fix-non-cplusplus-build.patch [new file with mode: 0644]
package/libxmlrpc/0003-non-wchar-build.patch [new file with mode: 0644]
package/libxmlrpc/0004-use-correct-curl-config.patch [new file with mode: 0644]
package/libxmlrpc/libxmlrpc-0001-fix-gennmtab-build.patch [deleted file]
package/libxmlrpc/libxmlrpc-0002-fix-non-cplusplus-build.patch [deleted file]
package/libxmlrpc/libxmlrpc-0003-non-wchar-build.patch [deleted file]
package/libxmlrpc/libxmlrpc-0004-use-correct-curl-config.patch [deleted file]

diff --git a/package/libxmlrpc/0001-fix-gennmtab-build.patch b/package/libxmlrpc/0001-fix-gennmtab-build.patch
new file mode 100644 (file)
index 0000000..8cdd932
--- /dev/null
@@ -0,0 +1,25 @@
+Fix build of host tool
+
+genmtab is a tool that needs to be built for the host as it is used
+during the compilation process of libxmlrpc. Its Makefile needs a bit
+of tuning to use the conventional CC_FOR_BUILD, CFLAGS_FOR_BUILD and
+LDFLAGS_FOR_BUILD variables.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/lib/expat/gennmtab/Makefile
+===================================================================
+--- a/lib/expat/gennmtab/Makefile
++++ b/lib/expat/gennmtab/Makefile
+@@ -40,9 +40,9 @@
+ dep: dep-common
+ gennmtab.o:%.o:%.c
+-      $(BUILDTOOL_CC) -c $< -o $@ $(CFLAGS_ALL) $(INCLUDES)
++      $(CC_FOR_BUILD) -c $< -o $@ $(CFLAGS_FOR_BUILD) $(INCLUDES)
+ gennmtab:%:%.o
+-      $(BUILDTOOL_CCLD) -o $@ $(LDFLAGS) $^
++      $(CC_FOR_BUILD) -o $@ $(LDFLAGS_FOR_BUILD) $^
+ include depend.mk
diff --git a/package/libxmlrpc/0002-fix-non-cplusplus-build.patch b/package/libxmlrpc/0002-fix-non-cplusplus-build.patch
new file mode 100644 (file)
index 0000000..efeb9cc
--- /dev/null
@@ -0,0 +1,27 @@
+Handle builds without C++
+
+libxmlrpc nicely handles the fact of being built without C++ support,
+except for one location, fixed by this patch.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/lib/util/Makefile
+===================================================================
+--- a/lib/util/Makefile
++++ b/lib/util/Makefile
+@@ -41,11 +41,14 @@
+ LIBOBJS = \
+   casprintf.o \
+   cmdline_parser.o \
+-  cmdline_parser_cpp.o \
+   getoptx.o \
+   string_parser.o \
+   stripcaseeq.o \
++ifeq ($(ENABLE_CPLUSPLUS),yes)
++LIBOBJS += cmdline_parser_cpp.o
++endif
++
+ .PHONY: all
+ all: $(LIBOBJS)
diff --git a/package/libxmlrpc/0003-non-wchar-build.patch b/package/libxmlrpc/0003-non-wchar-build.patch
new file mode 100644 (file)
index 0000000..1f04353
--- /dev/null
@@ -0,0 +1,24 @@
+Disable wide-char specific code
+
+The vast majority of the libxmlrpc code nicely handles the absence of
+wide char support, except at one location, which is fixed by this
+patch.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/src/xmlrpc_decompose.c
+===================================================================
+--- a/src/xmlrpc_decompose.c
++++ b/src/xmlrpc_decompose.c
+@@ -217,7 +217,11 @@
+         xmlrpc_strfree(*decompRootP->store.Tstring.valueP);
+         break;
+     case 'w':
++#if HAVE_UNICODE_WCHAR
+         free((void*)*decompRootP->store.TwideString.valueP);
++#else
++      XMLRPC_ASSERT(false);
++#endif
+         break;
+     case '6':
+         free((void*)*decompRootP->store.TbitString.valueP);
diff --git a/package/libxmlrpc/0004-use-correct-curl-config.patch b/package/libxmlrpc/0004-use-correct-curl-config.patch
new file mode 100644 (file)
index 0000000..ada0bd2
--- /dev/null
@@ -0,0 +1,22 @@
+Use correct curl-config program
+
+Instead of calling again curl-config in src/Makefile (which ends up
+calling the wrong curl-config: the one in the PATH instead of the one
+pointed at by the environment variables at configure time), let's use
+the CURL_LDADD variable which was computed at configure time.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -56,7 +56,7 @@
+   TRANSPORT_MODS += blddir/lib/curl_transport/curltransaction
+   TRANSPORT_MODS += blddir/lib/curl_transport/curlmulti
+   TRANSPORT_MODS += blddir/lib/curl_transport/lock_pthread
+-  TRANSPORT_LIBDEP += $(shell curl-config --libs)
++  TRANSPORT_LIBDEP += $(CURL_LDADD)
+ endif
+ ifeq ($(MUST_BUILD_LIBWWW_CLIENT),yes)
+   TRANSPORT_MODS += blddir/lib/libwww_transport/xmlrpc_libwww_transport
diff --git a/package/libxmlrpc/libxmlrpc-0001-fix-gennmtab-build.patch b/package/libxmlrpc/libxmlrpc-0001-fix-gennmtab-build.patch
deleted file mode 100644 (file)
index 8cdd932..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix build of host tool
-
-genmtab is a tool that needs to be built for the host as it is used
-during the compilation process of libxmlrpc. Its Makefile needs a bit
-of tuning to use the conventional CC_FOR_BUILD, CFLAGS_FOR_BUILD and
-LDFLAGS_FOR_BUILD variables.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/lib/expat/gennmtab/Makefile
-===================================================================
---- a/lib/expat/gennmtab/Makefile
-+++ b/lib/expat/gennmtab/Makefile
-@@ -40,9 +40,9 @@
- dep: dep-common
- gennmtab.o:%.o:%.c
--      $(BUILDTOOL_CC) -c $< -o $@ $(CFLAGS_ALL) $(INCLUDES)
-+      $(CC_FOR_BUILD) -c $< -o $@ $(CFLAGS_FOR_BUILD) $(INCLUDES)
- gennmtab:%:%.o
--      $(BUILDTOOL_CCLD) -o $@ $(LDFLAGS) $^
-+      $(CC_FOR_BUILD) -o $@ $(LDFLAGS_FOR_BUILD) $^
- include depend.mk
diff --git a/package/libxmlrpc/libxmlrpc-0002-fix-non-cplusplus-build.patch b/package/libxmlrpc/libxmlrpc-0002-fix-non-cplusplus-build.patch
deleted file mode 100644 (file)
index efeb9cc..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-Handle builds without C++
-
-libxmlrpc nicely handles the fact of being built without C++ support,
-except for one location, fixed by this patch.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/lib/util/Makefile
-===================================================================
---- a/lib/util/Makefile
-+++ b/lib/util/Makefile
-@@ -41,11 +41,14 @@
- LIBOBJS = \
-   casprintf.o \
-   cmdline_parser.o \
--  cmdline_parser_cpp.o \
-   getoptx.o \
-   string_parser.o \
-   stripcaseeq.o \
-+ifeq ($(ENABLE_CPLUSPLUS),yes)
-+LIBOBJS += cmdline_parser_cpp.o
-+endif
-+
- .PHONY: all
- all: $(LIBOBJS)
diff --git a/package/libxmlrpc/libxmlrpc-0003-non-wchar-build.patch b/package/libxmlrpc/libxmlrpc-0003-non-wchar-build.patch
deleted file mode 100644 (file)
index 1f04353..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Disable wide-char specific code
-
-The vast majority of the libxmlrpc code nicely handles the absence of
-wide char support, except at one location, which is fixed by this
-patch.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/src/xmlrpc_decompose.c
-===================================================================
---- a/src/xmlrpc_decompose.c
-+++ b/src/xmlrpc_decompose.c
-@@ -217,7 +217,11 @@
-         xmlrpc_strfree(*decompRootP->store.Tstring.valueP);
-         break;
-     case 'w':
-+#if HAVE_UNICODE_WCHAR
-         free((void*)*decompRootP->store.TwideString.valueP);
-+#else
-+      XMLRPC_ASSERT(false);
-+#endif
-         break;
-     case '6':
-         free((void*)*decompRootP->store.TbitString.valueP);
diff --git a/package/libxmlrpc/libxmlrpc-0004-use-correct-curl-config.patch b/package/libxmlrpc/libxmlrpc-0004-use-correct-curl-config.patch
deleted file mode 100644 (file)
index ada0bd2..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Use correct curl-config program
-
-Instead of calling again curl-config in src/Makefile (which ends up
-calling the wrong curl-config: the one in the PATH instead of the one
-pointed at by the environment variables at configure time), let's use
-the CURL_LDADD variable which was computed at configure time.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/src/Makefile
-===================================================================
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -56,7 +56,7 @@
-   TRANSPORT_MODS += blddir/lib/curl_transport/curltransaction
-   TRANSPORT_MODS += blddir/lib/curl_transport/curlmulti
-   TRANSPORT_MODS += blddir/lib/curl_transport/lock_pthread
--  TRANSPORT_LIBDEP += $(shell curl-config --libs)
-+  TRANSPORT_LIBDEP += $(CURL_LDADD)
- endif
- ifeq ($(MUST_BUILD_LIBWWW_CLIENT),yes)
-   TRANSPORT_MODS += blddir/lib/libwww_transport/xmlrpc_libwww_transport