linux: set a few more initramfs opts for newer kernels
authorMike Frysinger <vapier@gentoo.org>
Sat, 20 Nov 2010 03:38:05 +0000 (22:38 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 11 Dec 2010 00:41:00 +0000 (01:41 +0100)
Building with linux-2.6.36 and initramfs support causes the build to
pause while it prompts for newer options (uid/gid/compression).  So
have the build system inject the newer options into the linux config
automatically.  Older versions should just ignore these.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index feda4182cce213409c006de5533f889ee1e062cd..ab90c03e48d52b8dacdc4c44b63a1da78ba4e6eb 100644 (file)
@@ -106,6 +106,9 @@ ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
        touch $(BINARIES_DIR)/rootfs.initramfs
        $(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
        $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"$(BINARIES_DIR)/rootfs.initramfs\",$(@D)/.config)
+       $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_UID,0,$(@D)/.config)
+       $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0,$(@D)/.config)
+       $(call KCONFIG_DISABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_NONE,$(@D)/.config)
        $(call KCONFIG_ENABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_GZIP,$(@D)/.config)
 endif
        $(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig