package/netsurf: fix build of host tool convert_image
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 22 Jul 2019 05:17:15 +0000 (07:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 27 Jul 2019 20:22:40 +0000 (22:22 +0200)
Upstream commit
http://source.netsurf-browser.org/netsurf.git/commit/frontends/framebuffer/Makefile?id=40cdf498b9153685b4cefe576e59f6b41090912b

renamed the variable HOST_*FLAGS to BUILD_*FLAGS.

This breaks the build of the host tool convert_image when png.h is not
provided by the host system itself.

Fixes:
http://autobuild.buildroot.net/results/6ac/6ac71c7a41dd92a5fb924af9da7cedc40e745cfa/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/netsurf/netsurf.mk

index 30e8dc8b4fb23ff1c221523b08fd1f4df7ce98a1..b510a696497ccbb0218a5226e4c6b3a8a6e8e724 100644 (file)
@@ -36,8 +36,8 @@ ifeq ($(BR2_PACKAGE_NETSURF_SDL),y)
 NETSURF_DEPENDENCIES += sdl host-libpng
 NETSURF_FRONTEND = framebuffer
 NETSURF_CONFIG = \
-       HOST_CFLAGS='$(HOST_CFLAGS)' \
-       HOST_LDFLAGS='$(HOST_LDFLAGS) -lpng'
+       BUILD_CFLAGS='$(HOST_CFLAGS)' \
+       BUILD_LDFLAGS='$(HOST_LDFLAGS) -lpng'
 ifeq ($(BR2_PACKAGE_FREETYPE),y)
 NETSURF_DEPENDENCIES += freetype
 define NETSURF_FONTLIB_CONFIGURE_CMDS