Revert "dhcpcd: fix ipv6 related compile failure"
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 29 Apr 2015 20:54:11 +0000 (22:54 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 29 Apr 2015 20:58:05 +0000 (22:58 +0200)
This reverts commit 6b1f66643d782fc6f00e7436d41ceea6d88ad6bf.

It turns out to not really fix the build errors after all, so revert it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dhcpcd/dhcpcd.mk

index 756a660085cbdea90a0f0323bb49f8047724ffc4..405635197e572b461a61df0ac6ac7f6c26806960 100644 (file)
@@ -20,8 +20,8 @@ endif
 
 define DHCPCD_CONFIGURE_CMDS
        (cd $(@D); \
-       $(TARGET_CONFIGURE_OPTS) CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
-               ./configure --os=linux \
+       $(TARGET_CONFIGURE_OPTS) ./configure \
+               --os=linux \
                $(DHCPCD_CONFIG_OPTS) )
 endef