pciutils: bump to version 3.2.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 26 Apr 2013 14:24:17 +0000 (14:24 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 27 Apr 2013 18:04:57 +0000 (20:04 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pciutils/pciutils.mk

index 6219711fffb2bbccf9384d625139b2c814bf810a..2cd10c0b5dc8503ee488ea5088f2129c519c2a1e 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-PCIUTILS_VERSION = 3.1.10
+PCIUTILS_VERSION = 3.2.0
 PCIUTILS_SITE = ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
 PCIUTILS_INSTALL_STAGING = YES
 PCIUTILS_LICENSE = GPLv2+
@@ -24,6 +24,13 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
        PCIUTILS_DEPENDENCIES += busybox
 endif
 
+ifeq ($(BR2_PACKAGE_KMOD),y)
+       PCIUTILS_DEPENDENCIES += kmod
+       PCIUTILS_KMOD = yes
+else
+       PCIUTILS_KMOD = no
+endif
+
 define PCIUTILS_CONFIGURE_CMDS
        $(SED) 's/wget --no-timestamping/wget/' $(PCIUTILS_DIR)/update-pciids.sh
        $(SED) 's/uname -s/echo Linux/' \
@@ -43,6 +50,7 @@ define PCIUTILS_BUILD_CMDS
                SHARED=$(PCIUTILS_SHARED) \
                ZLIB=$(PCIUTILS_ZLIB) \
                DNS=$(PCIUTILS_DNS) \
+               LIBKMOD=$(PCIUTILS_KMOD) \
                PREFIX=/usr
 endef