valgrind: use the BR2_ARM_CPU_ARM* options
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Oct 2014 20:27:03 +0000 (22:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Nov 2014 22:54:16 +0000 (23:54 +0100)
Instead of using the exhaustive list of Cortex-A ARM cores, use
BR2_ARM_CPU_ARMV7A instead. We also fix a wrong comment that said the
Valgrind package could only be selected for Cortex-A8 and Cortex-A9,
which was true a long time ago, but was no longer true since it was
also enabled for all the other Cortex-A platforms.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/valgrind/Config.in
package/valgrind/valgrind.mk

index 253555ba48eafd867791e007aa40ee1b5b4c11d2..b7521b02172379234db63c876a31d2f243e807fa 100644 (file)
@@ -1,9 +1,8 @@
 config BR2_PACKAGE_VALGRIND
        bool "valgrind"
-       depends on BR2_i386 || BR2_x86_64 || BR2_cortex_a5 || \
-                  BR2_cortex_a7 || BR2_cortex_a8 || BR2_cortex_a9 || \
-                  BR2_cortex_a12 || BR2_cortex_a15 || BR2_powerpc || \
-                  BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el
+       depends on BR2_i386 || BR2_x86_64 || BR2_ARM_CPU_ARMV7A || \
+                  BR2_powerpc || BR2_mips || BR2_mipsel || BR2_mips64 || \
+                  BR2_mips64el
        help
          Tool for debugging and profiling Linux programs.
 
index 9b799410a14b640d18dbf2a7bc913fd95cac511b..b65e0488f2bbbbea04ffdc576f126ef30b4bf96f 100644 (file)
@@ -16,8 +16,8 @@ VALGRIND_AUTORECONF = YES
 # host tuple to determine whether it's being built for ARMv7 or
 # not. Therefore, we adjust the host tuple to specify we're on
 # ARMv7. The valgrind package is guaranteed, through Config.in, to
-# only be selected on Cortex A8 and Cortex A9 platforms.
-ifeq ($(BR2_cortex_a5)$(BR2_cortex_a7)$(BR2_cortex_a8)$(BR2_cortex_a9)$(BR2_cortex_a12)$(BR2_cortex_a15),y)
+# only be selected on ARMv7-A platforms.
+ifeq ($(BR2_ARM_CPU_ARMV7A),y)
 VALGRIND_CONF_OPTS += \
        --host=$(patsubst arm-%,armv7-%,$(GNU_TARGET_NAME))
 endif