package/lbreakout2: fix linking with intl
authorRomain Naour <romain.naour@openwide.fr>
Wed, 20 Aug 2014 11:25:21 +0000 (13:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 Aug 2014 13:34:47 +0000 (15:34 +0200)
lbreakout2 doen't build with (e)glibc toolchain when gettext package is selected.

With (e)glibc libintl is provided by the libc whereas with uClibc it's provided by gettext.

Linking with intl is only needed if the toolchain needs gettext and locale is set.

Fixes:
http://autobuild.buildroot.net/results/a77/a77dd3e18cc4a5e8300ab33eb532cc03d0156f7f/build-end.log

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lbreakout2/lbreakout2.mk

index 8f4e27d6c6ecb14c938f2e88663c3a57e83f1aa8..6087ca66a0b0c2a78677b44e831e780de956d4bf 100644 (file)
@@ -14,7 +14,7 @@ LBREAKOUT2_DEPENDENCIES = sdl libpng
 LBREAKOUT2_CONF_ENV = \
        SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config"
 
-ifeq ($(BR2_PACKAGE_GETTEXT),y)
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
 LBREAKOUT2_DEPENDENCIES += gettext
 LBREAKOUT2_CONF_ENV += LIBS=-lintl
 endif