intltool: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2010 12:18:06 +0000 (13:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Feb 2010 19:34:32 +0000 (20:34 +0100)
This XML internationalization set of tools is required to build
several of our packages, and may not be available on the host machine.

Only the host variant has been tested.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/intltool/Config.in [new file with mode: 0644]
package/intltool/intltook.mk [new file with mode: 0644]

index 00f3401aeab58176549d0011375749037a26265b..37cae2e834a7eb3f8b0ca8bd07a523dd6308a75b 100644 (file)
@@ -46,6 +46,7 @@ source "package/pkg-config/Config.in"
 source "package/readline/Config.in"
 source "package/valgrind/Config.in"
 source "package/pcre/Config.in"
+source "package/intltool/Config.in"
 
 comment "Other stuff"
 source "package/at/Config.in"
diff --git a/package/intltool/Config.in b/package/intltool/Config.in
new file mode 100644 (file)
index 0000000..94b34f7
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_INTLTOOL
+       bool "intltool"
+       help
+         Utility scripts for internationalizing XML
+
+        http://www.freedesktop.org/wiki/Software/intltool
\ No newline at end of file
diff --git a/package/intltool/intltook.mk b/package/intltool/intltook.mk
new file mode 100644 (file)
index 0000000..746ebb1
--- /dev/null
@@ -0,0 +1,16 @@
+#############################################################
+#
+# intltool
+#
+#############################################################
+INTLTOOL_VERSION:=0.40.6
+INTLTOOL_SOURCE:=intltool-$(INTLTOOL_VERSION).tar.bz2
+INTLTOOL_SITE:=http://ftp.acc.umu.se/pub/GNOME/sources/intltool/0.40/
+
+HOST_INTLTOOL_DEPENDENCIES = host-libxml-parser-perl
+HOST_INTLTOOL_CONF_OPT = \
+  PERLLIB=$(HOST_DIR)/usr/lib/perl
+
+$(eval $(call AUTOTARGETS,package,intltool))
+$(eval $(call AUTOTARGETS,package,intltool,host))
+