package/vdr: bump to version 2.4.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 30 Mar 2019 14:43:50 +0000 (15:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Mar 2019 11:56:52 +0000 (13:56 +0200)
- Add a dependency to glibc for execinfo.h and drop first patch (as it
  was useful only for uclibc)
- Add hash for license file

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vdr/0001-getloadavg.patch [deleted file]
package/vdr/0001-libjpeg.patch [new file with mode: 0644]
package/vdr/0002-libjpeg.patch [deleted file]
package/vdr/Config.in
package/vdr/vdr.hash
package/vdr/vdr.mk

diff --git a/package/vdr/0001-getloadavg.patch b/package/vdr/0001-getloadavg.patch
deleted file mode 100644 (file)
index 3937c83..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-Fix compilation with uClibc
-
-Ported from
-https://github.com/stschake/buildroot-grasshopper/blob/master/package/torsmo/torsmo-0.18-uclibc-getloadavg.patch
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
-diff -uwNr vdr-2.3.1.org/skinlcars.c vdr-2.3.1/skinlcars.c
---- vdr-2.3.1.org/skinlcars.c  2015-09-01 12:07:07.000000000 +0200
-+++ vdr-2.3.1/skinlcars.c      2016-07-31 21:00:11.000000000 +0200
-@@ -1099,6 +1099,44 @@
-      }
- }
-+/* uclibc and dietlibc do not have this junk -ReneR */
-+#if defined (__UCLIBC__) || defined (__dietlibc__)
-+static int getloadavg (double loadavg[], int nelem)
-+{
-+  int fd;
-+
-+  fd = open ("/proc/loadavg", O_RDONLY);
-+  if (fd < 0)
-+    return -1;
-+  else
-+    {
-+      char buf[65], *p;
-+      ssize_t nread;
-+      int i;
-+
-+      nread = read (fd, buf, sizeof buf - 1);
-+      close (fd);
-+      if (nread <= 0)
-+      return -1;
-+      buf[nread - 1] = '\0';
-+
-+      if (nelem > 3)
-+      nelem = 3;
-+      p = buf;
-+      for (i = 0; i < nelem; ++i)
-+      {
-+        char *endp;
-+        loadavg[i] = strtod (p, &endp);
-+        if (endp == p)
-+          return -1;
-+        p = endp;
-+      }
-+
-+      return i;
-+    }
-+}
-+#endif
-+
- void cSkinLCARSDisplayMenu::DrawLoad(void)
- {
-   if (yb04) {
diff --git a/package/vdr/0001-libjpeg.patch b/package/vdr/0001-libjpeg.patch
new file mode 100644 (file)
index 0000000..dbd1f12
--- /dev/null
@@ -0,0 +1,40 @@
+Fix compilation with libjpeg
+
+Patch inspired by upstream board:
+http://www.vdr-portal.de/board16-video-disk-recorder/board4-vdr-installation/p1189959-vdr-2-05-mit-libjpeg-9a-kommt-nicht-aus/#post1189959
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+diff -uNr vdr-2.3.1.org/tools.c vdr-2.3.1/tools.c
+--- vdr-2.3.1.org/tools.c      2015-09-10 15:17:55.000000000 +0200
++++ vdr-2.3.1/tools.c  2016-08-01 06:37:44.000000000 +0200
+@@ -1254,15 +1254,15 @@
+         }
+      else {
+         esyslog("ERROR: out of memory");
+-        return false;
++        return FALSE;
+         }
+      if (jcd->mem) {
+         cinfo->dest->next_output_byte = jcd->mem + Used;
+         cinfo->dest->free_in_buffer = jcd->size - Used;
+-        return true;
++        return TRUE;
+         }
+      }
+-  return false;
++  return FALSE;
+ }
+ static void JpegCompressTermDestination(j_compress_ptr cinfo)
+@@ -1307,8 +1307,8 @@
+   cinfo.in_color_space = JCS_RGB;
+   jpeg_set_defaults(&cinfo);
+-  jpeg_set_quality(&cinfo, Quality, true);
+-  jpeg_start_compress(&cinfo, true);
++  jpeg_set_quality(&cinfo, Quality, TRUE);
++  jpeg_start_compress(&cinfo, TRUE);
+   int rs = Width * 3;
+   JSAMPROW rp[Height];
diff --git a/package/vdr/0002-libjpeg.patch b/package/vdr/0002-libjpeg.patch
deleted file mode 100644 (file)
index dbd1f12..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-Fix compilation with libjpeg
-
-Patch inspired by upstream board:
-http://www.vdr-portal.de/board16-video-disk-recorder/board4-vdr-installation/p1189959-vdr-2-05-mit-libjpeg-9a-kommt-nicht-aus/#post1189959
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
-diff -uNr vdr-2.3.1.org/tools.c vdr-2.3.1/tools.c
---- vdr-2.3.1.org/tools.c      2015-09-10 15:17:55.000000000 +0200
-+++ vdr-2.3.1/tools.c  2016-08-01 06:37:44.000000000 +0200
-@@ -1254,15 +1254,15 @@
-         }
-      else {
-         esyslog("ERROR: out of memory");
--        return false;
-+        return FALSE;
-         }
-      if (jcd->mem) {
-         cinfo->dest->next_output_byte = jcd->mem + Used;
-         cinfo->dest->free_in_buffer = jcd->size - Used;
--        return true;
-+        return TRUE;
-         }
-      }
--  return false;
-+  return FALSE;
- }
- static void JpegCompressTermDestination(j_compress_ptr cinfo)
-@@ -1307,8 +1307,8 @@
-   cinfo.in_color_space = JCS_RGB;
-   jpeg_set_defaults(&cinfo);
--  jpeg_set_quality(&cinfo, Quality, true);
--  jpeg_start_compress(&cinfo, true);
-+  jpeg_set_quality(&cinfo, Quality, TRUE);
-+  jpeg_start_compress(&cinfo, TRUE);
-   int rs = Width * 3;
-   JSAMPROW rp[Height];
index 65117f5461b0e23881f3dd8470b6db9f9e01347c..712364a971382603b4e4092655dfa1b49b0b4ddd 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_VDR
        depends on !BR2_STATIC_LIBS
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_9
-       depends on !BR2_TOOLCHAIN_USES_MUSL # _nl_msg_cat_cntr
+       depends on BR2_TOOLCHAIN_USES_GLIBC # execinfo.h
        depends on BR2_USE_MMU # fork()
        depends on BR2_USE_WCHAR
        select BR2_PACKAGE_FONTCONFIG
@@ -18,9 +18,9 @@ config BR2_PACKAGE_VDR
 
          http://www.tvdr.de
 
-comment "vdr needs a glibc or uClibc toolchain w/ C++, dynamic library, NPTL, wchar, headers >= 3.9"
+comment "vdr needs a glibc toolchain w/ C++, dynamic library, NPTL, wchar, headers >= 3.9"
        depends on BR2_USE_MMU
        depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS || \
                !BR2_TOOLCHAIN_HAS_THREADS_NPTL || \
-               BR2_TOOLCHAIN_USES_MUSL || !BR2_USE_WCHAR || \
+               !BR2_TOOLCHAIN_USES_GLIBC || !BR2_USE_WCHAR || \
                !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_9
index 2ced98d9670cbed40bf5844f1d37f03c81bbe5a4..e9cee9a5b510e23212f1ae3483145ed1f0ace88c 100644 (file)
@@ -1,4 +1,5 @@
-# From https://www.linuxtv.org/pipermail/vdr/2017-May/029263.html
-md5 01fabef4d20ec01f11d53354d99a9642  vdr-2.3.5.tar.bz2
+# From https://www.linuxtv.org/pipermail/vdr/2018-April/029407.html
+md5 12c6a3abeadfa915fcfe736bb047a3ab  vdr-2.4.0.tar.bz2
 # Locally computed
-sha256 323fd01e4f8daef24bbdcb906023d18c998a204a22de110d1cb0089532e818b5  vdr-2.3.5.tar.bz2
+sha256 93af49fe87048073dc38ef5e6c71e9704344d730f21c261afac69e3c937f8cce  vdr-2.4.0.tar.bz2
+sha256 ddb9db7630752f8fdc6898f7c99a99eaeeac5213627ecb093df9c82f56175dc7  COPYING
index 242c5798d141cd206faed99a727974b54a6c15d0..67e160c8f05c7c65d4135579542e45a73864d589 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-VDR_VERSION = 2.3.5
+VDR_VERSION = 2.4.0
 VDR_SOURCE = vdr-$(VDR_VERSION).tar.bz2
-VDR_SITE = ftp://ftp.tvdr.de/vdr/Developer
+VDR_SITE = ftp://ftp.tvdr.de/vdr
 VDR_LICENSE = GPL-2.0+
 VDR_LICENSE_FILES = COPYING
 VDR_INSTALL_STAGING = YES