package/qemu: enable nios2 support in host-qemu
authorJugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Sun, 5 May 2019 16:53:53 +0000 (18:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 2 Aug 2019 21:48:14 +0000 (23:48 +0200)
This change enables host qemu support for nios2 which among other
things allows to test this architecture in gitlab.

Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Reviewed-by: Thomas Huth <huth@tuxfamily.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/Config.in.host
package/qemu/qemu.mk

index effe58b211a074ed1eff2074ec16126164739d88..b1c3ab685e4ca1adacc17437624a01c2af2b1010 100644 (file)
@@ -10,6 +10,7 @@ config BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS
        default y if BR2_microblazebe
        default y if BR2_mips
        default y if BR2_mipsel
+       default y if BR2_nios2
        default y if BR2_powerpc
        default y if BR2_powerpc64
        default y if BR2_powerpc64le
index 2c11f64ad04d512568ba7d5308f2f5c5762e61e3..c5d33d7d3cdcf90382b9f06af5f04365ef643946 100644 (file)
@@ -177,6 +177,7 @@ HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2 host-pixman
 #       mipsel          mipsel
 #       mips64          mips64
 #       mips64el        mips64el
+#       nios2           nios2
 #       powerpc         ppc
 #       powerpc64       ppc64
 #       powerpc64le     ppc64 (system) / ppc64le (usermode)