systemd: fix build on uClibc
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 31 Mar 2012 21:57:35 +0000 (23:57 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 31 Mar 2012 21:57:35 +0000 (23:57 +0200)
Patch based on similar patch in openembedded.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/systemd/systemd-uclibc-fix.patch [new file with mode: 0644]
package/systemd/systemd.mk

diff --git a/package/systemd/systemd-uclibc-fix.patch b/package/systemd/systemd-uclibc-fix.patch
new file mode 100644 (file)
index 0000000..24c32ab
--- /dev/null
@@ -0,0 +1,40 @@
+[PATCH] fix build with uClibc
+
+Based on OE patch from Khem Raj:
+
+http://cgit.openembedded.org/meta-openembedded/tree/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
+
+But extended to also cover execvpe (OE carries a patch adding execvpe
+support to uClibc).
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ src/macro.h |   15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
+
+Index: systemd-37/src/macro.h
+===================================================================
+--- systemd-37.orig/src/macro.h
++++ systemd-37/src/macro.h
+@@ -27,6 +27,21 @@
+ #include <sys/uio.h>
+ #include <inttypes.h>
++#ifdef __UCLIBC__
++/* uclibc does not implement mkostemp GNU extension */
++#define mkostemp(x,y) mkstemp(x)
++/* uclibc does not implement execvpe GNU extension */
++#ifndef _GNU_SOURCE
++#define _GNU_SOURCE
++#endif
++#include <unistd.h>
++static inline int execvpe(const char *file, char *const argv[],
++                          char *const envp[])
++{
++        environ = (char **)envp;
++        return execvp(file, argv);
++}
++#endif
+ #define _printf_attr_(a,b) __attribute__ ((format (printf, a, b)))
+ #define _sentinel_ __attribute__ ((sentinel))
+ #define _noreturn_ __attribute__((noreturn))
index fc49f3c7f4f670dae76d146f932a8da16b189886..eded4720838ecf5538e19a12c3a54a83c34c7a5a 100644 (file)
@@ -41,6 +41,9 @@ else
        SYSTEMD_CONF_OPT += --disable-acl
 endif
 
+# mq_getattr needs -lrt
+SYSTEMD_MAKE_OPT += LIBS=-lrt
+
 define SYSTEMD_INSTALL_INIT_HOOK
        ln -fs ../bin/systemd $(TARGET_DIR)/sbin/init
        ln -fs ../bin/systemctl $(TARGET_DIR)/sbin/halt