pkg-python: also pass PYTHONPATH when building distutils packages
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Feb 2014 20:48:52 +0000 (21:48 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Feb 2014 20:41:15 +0000 (21:41 +0100)
With the upcoming bump of Python 2.x, it will become important that
the PYTHONPATH is passed whenever we build third-party packages, be
they using the distutils build mechanism, or the setuptools build
mechanism. This is because passing PYTHONPATH is what will allow
Python to find a special Python module that contains all the
compiler/library/headers definitions that are relevant when
cross-compiling.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-python.mk

index 65c9b4adc38f5c3235a69bce0f6d0b5e66333619..c423f7a5e225ef85ed453aa2580922156183ba12 100644 (file)
@@ -28,6 +28,7 @@ PKG_PYTHON_DISTUTILS_ENV = \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        LDSHARED="$(TARGET_CROSS)gcc -shared" \
        CROSS_COMPILING=yes \
+       PYTHONPATH="$(PYTHON_PATH)" \
        _python_sysroot=$(STAGING_DIR) \
        _python_prefix=/usr \
        _python_exec_prefix=/usr