package/sdl_sound: add optional support for libmodplug
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 14:56:47 +0000 (15:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 17:27:43 +0000 (18:27 +0100)
When libmodplug was compiled before, sdl_sound will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/libSDL_sound-1.0.so.1.0.2 | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libmodplug.so.1]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sdl_sound/sdl_sound.mk

index 416f3812159bdb043997da81c5f38132b80a7737..faf88ae84e34b09adbd1670aae62a992ca668297 100644 (file)
@@ -21,6 +21,13 @@ ifeq ($(BR2_PACKAGE_FLAC),y)
 SDL_SOUND_DEPENDENCIES += flac # is only used if ogg is also enabled
 endif
 
+ifeq ($(BR2_PACKAGE_LIBMODPLUG),y)
+SDL_SOUND_CONF_OPTS += --enable-modplug
+SDL_SOUND_DEPENDENCIES += libmodplug
+else
+SDL_SOUND_CONF_OPTS += --disable-modplug
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
 SDL_SOUND_DEPENDENCIES += libvorbis
 endif