lighttpd: fix compilation without largefile support
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 17 Sep 2008 21:35:51 +0000 (21:35 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 17 Sep 2008 21:35:51 +0000 (21:35 -0000)
lighttpd uses --disable-lfs instead of --disable-largefile.
Remove redundant configure args while we're at it.

package/lighttpd/lighttpd.mk

index 67e486d154abee0b95d1b016a107ddea360037d6..4c6e9e1ff92f345d5fd23dfd214015913e4d9fbd 100644 (file)
@@ -10,18 +10,18 @@ LIGHTTPD_INSTALL_STAGING = NO
 LIGHTTPD_INSTALL_TARGET = YES
 LIGHTTPD_DEPENDENCIES = uclibc
 LIGHTTPD_CONF_ENV =
+
+ifneq ($(BR2_LARGEFILE),y)
+LIGHTTPD_LFS:=$(DISABLE_LARGEFILE) --disable-lfs
+endif
+
 LIGHTTPD_CONF_OPT = \
-       --target=$(GNU_TARGET_NAME) \
-       --host=$(GNU_TARGET_NAME) \
-       --build=$(GNU_HOST_NAME) \
-       --prefix=/usr \
        --libdir=/usr/lib/lighttpd \
        --libexecdir=/usr/lib \
-       --sysconfdir=/etc \
        --localstatedir=/var \
        --program-prefix="" \
        $(DISABLE_IPV6) \
-       $(DISABLE_LARGEFILE)
+       $(LIGHTTPD_LFS)
 
 ifeq ($(strip $(BR2_PACKAGE_LIGHTTPD_OPENSSL)),y)
 LIGHTTPD_DEPENDENCIES += openssl