package/python-aiorwlock: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Fri, 7 Dec 2018 00:08:04 +0000 (08:08 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 9 Dec 2018 16:11:16 +0000 (17:11 +0100)
Read write lock for asyncio.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-aiorwlock/Config.in [new file with mode: 0644]
package/python-aiorwlock/python-aiorwlock.hash [new file with mode: 0644]
package/python-aiorwlock/python-aiorwlock.mk [new file with mode: 0644]

index 681547f84149684851c2a448cb8c5175578c9889..4a2a4c16fff59012777b41c09b8ae03c72fd6b15 100644 (file)
@@ -1000,6 +1000,7 @@ F:        package/python-aiohttp-security/
 F:     package/python-aiohttp-session/
 F:     package/python-aiohttp-sse/
 F:     package/python-aiojobs/
+F:     package/python-aiorwlock/
 F:     package/python-async-timeout/
 F:     package/python-cchardet/
 F:     package/python-multidict/
index db72a1a126d62f3cf17a69a85e91425a3016e48d..5dbf7a510ecd62f0a31007b8fae981267e92b725 100644 (file)
@@ -805,6 +805,7 @@ menu "External python modules"
        source "package/python-aiohttp-security/Config.in"
        source "package/python-aiohttp-session/Config.in"
        source "package/python-aiohttp-sse/Config.in"
+       source "package/python-aiorwlock/Config.in"
        source "package/python-aiojobs/Config.in"
        source "package/python-alsaaudio/Config.in"
        source "package/python-argh/Config.in"
diff --git a/package/python-aiorwlock/Config.in b/package/python-aiorwlock/Config.in
new file mode 100644 (file)
index 0000000..afdc27d
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_AIORWLOCK
+       bool "python-aiorwlock"
+       depends on BR2_PACKAGE_PYTHON3
+       help
+         Read write lock for asyncio.
+
+         https://github.com/aio-libs/aiorwlock
diff --git a/package/python-aiorwlock/python-aiorwlock.hash b/package/python-aiorwlock/python-aiorwlock.hash
new file mode 100644 (file)
index 0000000..51d1a29
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/aiorwlock/json
+md5    ee741761e4c9b1612e9dccf7f8bccdd0  aiorwlock-0.5.0.tar.gz
+sha256 3cd892576d024934d72c3dd098033f276ace3495e71a1197daa8d21409a52174  aiorwlock-0.5.0.tar.gz
+# Locally computed sha256 checksums
+sha256 56fb2baf14d84c59c15abbfbb1fdf30a724017e2ce97894a8236764513d10397  LICENSE
diff --git a/package/python-aiorwlock/python-aiorwlock.mk b/package/python-aiorwlock/python-aiorwlock.mk
new file mode 100644 (file)
index 0000000..ca6aa25
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-aiorwlock
+#
+################################################################################
+
+PYTHON_AIORWLOCK_VERSION = 0.5.0
+PYTHON_AIORWLOCK_SOURCE = aiorwlock-$(PYTHON_AIORWLOCK_VERSION).tar.gz
+PYTHON_AIORWLOCK_SITE = https://files.pythonhosted.org/packages/0c/20/d30f332e6ecb2be467ab5603e277b26e3a8eb2a72f75bf8d309bdd4c0c82
+PYTHON_AIORWLOCK_SETUP_TYPE = setuptools
+PYTHON_AIORWLOCK_LICENSE = Apache-2.0
+PYTHON_AIORWLOCK_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))