projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1b887cf
)
package/php: fix build without zlib
author
Fabrice Fontaine
<fontaine.fabrice@gmail.com>
Sun, 8 Mar 2020 17:05:56 +0000
(18:05 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Sun, 8 Mar 2020 19:08:21 +0000
(20:08 +0100)
Build will fail if zlib is not found and mysqlnd compression support
is not disabled since version 7.4.1 and
https://github.com/php/php-src/commit/
ee4295b4ce421003c2e1d2af98066826deb23319
Fixes:
- http://autobuild.buildroot.org/results/
9496d81437dba55d22a03762dcfe60d632115ab5
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php/php.mk
patch
|
blob
|
history
diff --git
a/package/php/php.mk
b/package/php/php.mk
index d4829645e8d6422c8feade9f4e6102c0ac5344c9..c0abecad190d9480712abaafe92db5ba431d07e7 100644
(file)
--- a/
package/php/php.mk
+++ b/
package/php/php.mk
@@
-174,6
+174,8
@@
endif
ifneq ($(BR2_PACKAGE_PHP_EXT_ZLIB)$(BR2_PACKAGE_PHP_EXT_ZIP),)
PHP_CONF_OPTS += --with-zlib=$(STAGING_DIR)/usr
PHP_DEPENDENCIES += zlib
+else
+PHP_CONF_OPTS += --disable-mysqlnd_compression_support
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_GETTEXT),y)