package/qt5tools: enable build of host qdoc
authorYann E. MORIN <yann.morin@orange.com>
Tue, 6 Aug 2019 07:35:25 +0000 (09:35 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 11 Oct 2019 22:49:07 +0000 (00:49 +0200)
qdoc was previously built as part of qtbase (in the pre-5.6 era), but
with qt-5.6 it is now part of qttools.

With qt-5.12, it needs libclang to build, so be it...

Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
Cc: Peter Seiderer <ps.report@gmx.net>
Cc: Julien Corjon <corjon.j@ecagroup.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/qt5/qt5tools/Config.in
package/qt5/qt5tools/qt5tools.mk

index 20f00f6b2f1d8a9c5fdc8e5b0bc50188c173ffc5..7e79a679b3399559e3f86f300e26ba92cf87f8bf 100644 (file)
@@ -17,6 +17,16 @@ config BR2_PACKAGE_QT5TOOLS_LINGUIST_TOOLS
          This option enables the linguist host tools
          lconvert, lrelease and lupdate.
 
+config BR2_PACKAGE_QT5TOOLS_QDOC_TOOL
+       bool "qdoc host tool"
+       depends on !BR2_PACKAGE_QT5_VERSION_LATEST \
+               || BR2_HOST_GCC_AT_LEAST_4_8 # host-clang
+       help
+         This option enables the qdoc host tool.
+
+comment "qdoc host tool needs host gcc >= 4.8"
+       depends on BR2_PACKAGE_QT5_VERSION_LATEST && !BR2_HOST_GCC_AT_LEAST_4_8
+
 config BR2_PACKAGE_QT5TOOLS_PIXELTOOL
        bool "pixeltool"
        select BR2_PACKAGE_QT5BASE_GUI
index a972756d3ac0a15b01ba5f86ee39530b09cdeb0d..0d00022998a95f44f49f498e1d000f0ecf49eae0 100644 (file)
@@ -29,11 +29,13 @@ endif
 
 QT5TOOLS_BUILD_DIRS_$(BR2_PACKAGE_QT5TOOLS_LINGUIST_TOOLS) += \
        linguist/lconvert linguist/lrelease linguist/lupdate
-ifeq ($(BR2_PACKAGE_QT5TOOLS_LINGUIST_TOOLS),y)
-# use install target to copy cmake module files
-define QT5TOOLS_INSTALL_STAGING_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src/linguist install
-endef
+QT5TOOLS_INSTALL_STAGING_DIR_$(BR2_PACKAGE_QT5TOOLS_LINGUIST_TOOLS) += \
+       linguist
+
+ifeq ($(BR2_PACKAGE_QT5TOOLS_QDOC_TOOL),y)
+QT5TOOLS_BUILD_DIRS_y += qdoc
+QT5TOOLS_INSTALL_STAGING_DIR_y += qdoc
+QT5TOOLS_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5_VERSION_LATEST),host-clang)
 endif
 
 QT5TOOLS_BUILD_DIRS_$(BR2_PACKAGE_QT5TOOLS_PIXELTOOL) += pixeltool
@@ -58,6 +60,12 @@ define QT5TOOLS_BUILD_CMDS
                $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src/$(p)$(sep))
 endef
 
+# use install target to copy cmake module files
+define QT5TOOLS_INSTALL_STAGING_CMDS
+       $(foreach p,$(QT5TOOLS_INSTALL_STAGING_DIR_y), \
+               $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src/$(p) install$(sep))
+endef
+
 define QT5TOOLS_INSTALL_TARGET_CMDS
        $(foreach p,$(QT5TOOLS_INSTALL_TARGET_y), \
                $(INSTALL) -D -m0755 $(@D)/bin/$(p) $(TARGET_DIR)/usr/bin/$(p)$(sep))