package/netsnmp: fix script net-snmp-create-v3-user's usage of 'ps'.
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>
Wed, 31 Mar 2021 08:14:47 +0000 (10:14 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 31 Mar 2021 19:49:09 +0000 (21:49 +0200)
net-snmp-create-v3-user uses ps to check if snmpd is running.  To know
how to invoke 'ps', the build system use 'which ps' and does other
checks for the output format of 'ps', therefore inspecting 'ps' on the
build machine instead of the target.

If the build machine runs a OS like Debian, that uses a merged-usr and a
PATH of '/usr/bin:/bin', then 'which ps' returns /usr/bin/ps, which will
not work on the target if it does not also use a merged-usr.

Hardcode 'ps' to be /bin/ps to fix this issue and to improve build
reproducibility.

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/netsnmp/netsnmp.mk

index 5b22d1a063ac52b104cd53628c165e7d29679c53..1a9a7760330d9213b5065afd5e24edb407a65f1b 100644 (file)
@@ -12,7 +12,9 @@ NETSNMP_LICENSE_FILES = COPYING
 NETSNMP_CPE_ID_VENDOR = net-snmp
 NETSNMP_CPE_ID_PRODUCT = $(NETSNMP_CPE_ID_VENDOR)
 NETSNMP_INSTALL_STAGING = YES
-NETSNMP_CONF_ENV = ac_cv_NETSNMP_CAN_USE_SYSCTL=no
+NETSNMP_CONF_ENV = \
+       ac_cv_NETSNMP_CAN_USE_SYSCTL=no \
+       ac_cv_path_PSPROG=/bin/ps
 NETSNMP_CONF_OPTS = \
        --with-persistent-directory=/var/lib/snmp \
        --with-defaults \