package/gpsd: unconditionally enable NTP time hinting support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 6 Aug 2019 05:19:20 +0000 (07:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 7 Aug 2019 14:30:47 +0000 (16:30 +0200)
Mandatory LEAP* defines are only enabled when TIMEHINT_ENABLE is
enabled: https://gitlab.com/gpsd/gpsd/blob/master/gpsd.h#L293

And TIMEHINT_ENABLE is only enabled when NTPSHM_ENABLE is enabled:
https://gitlab.com/gpsd/gpsd/blob/master/gpsd.h#L109

Upstream has entirely dropped the TIMEHINT_ENABLE option:

  https://gitlab.com/gpsd/gpsd/commit/8546be5f1eee36fd3fc66f09f2adfc18814d574c

So, for the time being, we simply enable it unconditionally.

Fixes:

  http://autobuild.buildroot.net/results/44639b8fe407bee30ac96ab54b8037439f3dac88/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: drop Config.in.legacy, improve commit log]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gpsd/Config.in
package/gpsd/gpsd.mk

index 685830aed300c0fb3de09b8552d6d6c2eb1b9161..22f7e6e1d93bae958ec32c3f16e07867fc5e34cb 100644 (file)
@@ -44,9 +44,6 @@ config BR2_PACKAGE_GPSD_PROFILING
 comment "profiling support not available with uClibc-based toolchain"
        depends on !BR2_TOOLCHAIN_USES_GLIBC
 
-config BR2_PACKAGE_GPSD_NTP_SHM
-       bool "NTP time hinting support"
-
 config BR2_PACKAGE_GPSD_PPS
        bool "PPS time syncing support"
        select BR2_PACKAGE_GPSD_NTP_SHM
index f1c7bb7349c7ee2f473493bfa166dccee572f9f1..79d2ccfeaaa414f59f98ab716b02bf724b695e62 100644 (file)
@@ -24,7 +24,8 @@ GPSD_SCONS_OPTS = \
        sysroot=$(STAGING_DIR) \
        strip=no \
        python=no \
-       qt=no
+       qt=no \
+       ntpshm=yes
 
 ifeq ($(BR2_PACKAGE_NCURSES),y)
 GPSD_DEPENDENCIES += ncurses
@@ -161,9 +162,6 @@ GPSD_SCONS_OPTS += ublox=no
 endif
 
 # Features
-ifneq ($(BR2_PACKAGE_GPSD_NTP_SHM),y)
-GPSD_SCONS_OPTS += ntpshm=no
-endif
 ifneq ($(BR2_PACKAGE_GPSD_PPS),y)
 GPSD_SCONS_OPTS += pps=no
 endif