- iff the cross-compiler supports certain mtune,march,mabi flags then use them for...
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 23 Jul 2007 11:37:25 +0000 (11:37 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 23 Jul 2007 11:37:25 +0000 (11:37 -0000)
  This should make it obvious if the wrong compiler is used to build the target.

package/Makefile.in

index fc2ce7229b58200d66a2a4538e573db672c04537..0384dfa0c8318001b94657e4805dbd2b2b8a3cad 100644 (file)
@@ -34,6 +34,22 @@ TARGET_CFLAGS+= $(BR2_SYSROOT) $(BR2_ISYSROOT)
 #TARGET_LDFLAGS=-Wl,$(BR2_SYSROOT)
 endif
 
+CC_TARGET_TUNE_:=$(strip $(subst ",,BR2_GCC_TARGET_TUNE))
+#"))
+CC_TARGET_ARCH_:=$(strip $(subst ",,BR2_GCC_TARGET_ARCH))
+#"))
+CC_TARGET_ABI_:=$(strip $(subst ",,BR2_GCC_TARGET_ABI))
+#"))
+ifneq ($(CC_TARGET_TUNE_),)
+TARGET_CFLAGS+=-mtune=$(CC_TARGET_TUNE_)
+endif
+ifneq ($(CC_TARGET_ARCH_),)
+TARGET_CFLAGS+=-march=$(CC_TARGET_ARCH_)
+endif
+ifneq ($(CC_TARGET_ABI_),)
+TARGET_CFLAGS+=-mabi=$(CC_TARGET_ABI_)
+endif
+
 ifneq ($(BR2_PREFER_STATIC_LIB),y)
 ifeq ($(BR2_x86_64),y)
 TARGET_CFLAGS+=-fPIC -DPIC