qt5base: install libQt5XcbQpa.so for xcb backend
authorMatthew Shyu <matthew.shyu@amlogic.com>
Wed, 19 Aug 2015 09:48:15 +0000 (17:48 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 19 Aug 2015 19:16:16 +0000 (21:16 +0200)
When the XCB backend is selected, the libqxcb.so plugin is installed,
and is linked against libQt5XcbQpa.so. However, until, Buildroot was
not installing this library. This commit fixes this.

[Thomas: tweak commit log.]

Signed-off-by: Matthew Shyu <matthew.shyu@amlogic.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5base/qt5base.mk

index 753b0696f58f4244001c9d2d9821e2944c157ccd..e80c20c638134b41bbeecb3a69c95a6ae8f2543b 100644 (file)
@@ -156,6 +156,7 @@ QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_EXAMPLES),-make,-nomake) ex
 
 # Build the list of libraries to be installed on the target
 QT5BASE_INSTALL_LIBS_y                                 += Qt5Core
+QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_XCB)        += Qt5XcbQpa
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK)    += Qt5Network
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_CONCURRENT) += Qt5Concurrent
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_SQL)        += Qt5Sql