vlc: fix build on or1k
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 10 Sep 2018 21:54:51 +0000 (23:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 12 Sep 2018 19:12:42 +0000 (21:12 +0200)
vlc 3.0.4 is also affected by gcc bug internal compiler error on or1k

hw/vaapi/vlc_vaapi.c: In function 'pool_pic_destroy_cb':
hw/vaapi/vlc_vaapi.c:568:1: internal compiler error: in merge_overlapping_regs, at regrename.c:304
 }

Fixes:
 - http://autobuild.buildroot.org/results/771e88e7fb06714dd4b7246f82b95dffcedde343

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 073dbf5b40e5c0e312edd239fd6c74f155426ce6..73f84d5eb235b0c2f1851ec9c5f763effd9faafc 100644 (file)
@@ -17,7 +17,7 @@ VLC_INSTALL_STAGING = YES
 
 # gcc bug internal compiler error: in merge_overlapping_regs, at
 # regrename.c:304. This bug is fixed since gcc 6.
-ifeq ($(BR2_microblaze):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),y:)
+ifeq ($(BR2_microblaze)$(BR2_or1k):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),y:)
 VLC_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -O0"
 VLC_CONF_OPTS += --disable-optimizations
 endif