package/dhcpcd: add udev optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 26 Dec 2020 17:17:45 +0000 (18:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Dec 2020 17:28:15 +0000 (18:28 +0100)
udev is an optional dependency (enabled by default) since version 6.1.0:
https://github.com/rsmarples/dhcpcd/commit/12bbc8cb5c7507be15a7e0af4140c3d81125c46c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dhcpcd/dhcpcd.mk

index 7b69602605d979a8d9c4e31513a9e4c2b3c491ce..4900e0581fa513490723074e1d0c95979ac4195b 100644 (file)
@@ -16,6 +16,13 @@ DHCPCD_CONFIG_OPTS = \
        --os=linux \
        --privsepuser=dhcpcd
 
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+DHCPCD_CONFIG_OPTS += --with-udev
+DHCPCD_DEPENDENCIES += udev
+else
+DHCPCD_CONFIG_OPTS += --without-udev
+endif
+
 ifeq ($(BR2_STATIC_LIBS),y)
 DHCPCD_CONFIG_OPTS += --enable-static
 endif