package/gnutls: drop unrecognized option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 29 Mar 2021 19:30:58 +0000 (21:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 30 Mar 2021 19:45:10 +0000 (21:45 +0200)
crywrap has been dropped since version 3.6.12 and
https://github.com/gnutls/gnutls/commit/c991b5223140e4ef311afac0f25272e602238826

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gnutls/Config.in
package/gnutls/gnutls.mk

index 15b930b6bd5b016336475f693cde5fdda04dc1b2..cd853d1e742f7b12a37b10692ca597a21ed35bb5 100644 (file)
@@ -23,8 +23,6 @@ config BR2_PACKAGE_GNUTLS_OPENSSL
 
 config BR2_PACKAGE_GNUTLS_TOOLS
        bool "install tools"
-       select BR2_PACKAGE_ARGP_STANDALONE \
-               if BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_MUSL
        help
          Install GnuTLS command line tools for various cryptographic
          tasks.
index 65bb4893e85c699f2d4bfe07718af6e8ef5725d3..cf2dedb590eb1f6d2e38e63a674ba247f3ebd257 100644 (file)
@@ -47,20 +47,6 @@ GNUTLS_CONF_OPTS += \
        --with-libregex-cflags="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --cflags`" \
        --with-libregex-libs="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --libs`"
 
-# Consider crywrap as part of tools because it needs WCHAR, and it's so too
-ifeq ($(BR2_PACKAGE_GNUTLS_TOOLS),)
-GNUTLS_CONF_OPTS += --disable-crywrap
-endif
-
-# Prerequisite for crywrap
-ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
-GNUTLS_LIBS += -largp
-GNUTLS_DEPENDENCIES += argp-standalone
-endif
-
-# libidn support for nommu must exclude the crywrap wrapper (uses fork)
-GNUTLS_CONF_OPTS += $(if $(BR2_USE_MMU),,--disable-crywrap)
-
 ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
 GNUTLS_CONF_OPTS += --enable-cryptodev
 GNUTLS_DEPENDENCIES += cryptodev-linux