cannelloni: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 3 Mar 2016 12:01:47 +0000 (13:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 19:17:25 +0000 (21:17 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
[Thomas: fix license, it's GPLv2, not GPLv2+.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/cannelloni/Config.in [new file with mode: 0644]
package/cannelloni/cannelloni.hash [new file with mode: 0644]
package/cannelloni/cannelloni.mk [new file with mode: 0644]

index bd76669fb81ada511c20333b3069832cb033f58d..234d105f251bd59fd176d35a4a76d2cb068dcd2b 100644 (file)
@@ -1349,6 +1349,7 @@ menu "Networking applications"
        source "package/bwm-ng/Config.in"
        source "package/c-icap/Config.in"
        source "package/c-icap-modules/Config.in"
+       source "package/cannelloni/Config.in"
        source "package/can-utils/Config.in"
        source "package/chrony/Config.in"
        source "package/civetweb/Config.in"
diff --git a/package/cannelloni/Config.in b/package/cannelloni/Config.in
new file mode 100644 (file)
index 0000000..0938159
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_CANNELLONI
+       bool "cannelloni"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_USE_MMU # lksctp-tools
+       depends on BR2_TOOLCHAIN_HAS_THREADS # lksctp-tools
+       select BR2_PACKAGE_LKSCTP_TOOLS
+       help
+         A SocketCAN over Ethernet tunnel. The tunnel supports both
+         UDP and SCTP protocols.
+
+         https://github.com/mguentner/cannelloni
+
+comment "cannelloni needs a toolchain w/ C++, threads"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
diff --git a/package/cannelloni/cannelloni.hash b/package/cannelloni/cannelloni.hash
new file mode 100644 (file)
index 0000000..826af9b
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256  7341b76e2af056ecbcfc9fabc6e67c88234666be60f1eb099390c61bb9925856  cannelloni-v0.5.tar.gz
diff --git a/package/cannelloni/cannelloni.mk b/package/cannelloni/cannelloni.mk
new file mode 100644 (file)
index 0000000..efbe43d
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# cannelloni
+#
+################################################################################
+
+CANNELLONI_VERSION = v0.5
+CANNELLONI_SITE = $(call github,mguentner,cannelloni,$(CANNELLONI_VERSION))
+CANNELLONI_LICENSE = GPLv2
+CANNELLONI_LICENSE_FILES = gpl-2.0.txt
+CANNELLONI_DEPENDENCIES = lksctp-tools
+
+$(eval $(cmake-package))