infra: remove unused helper function pkgparentdir
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 5 Feb 2014 09:44:04 +0000 (10:44 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 5 Feb 2014 11:10:44 +0000 (12:10 +0100)
Thanks to the previous patches, no-one is using pkgparentdir anymore, so
remove it.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-utils.mk

index 51dd7384baeb8a18643cd39e35be1da32f8cbbff..91a198160fd4bad3f74f05bae27ead73376963d9 100644 (file)
@@ -55,12 +55,9 @@ endef
 # Helper functions to determine the name of a package and its
 # directory from its makefile directory, using the $(MAKEFILE_LIST)
 # variable provided by make. This is used by the *TARGETS macros to
-# automagically find where the package is located. Note that the
-# pkgdir macro is carefully written to handle the case of the Linux
-# package, for which the package directory is an empty string.
+# automagically find where the package is located.
 pkgdir       = $(dir $(lastword $(MAKEFILE_LIST)))
 pkgname      = $(lastword $(subst /, ,$(pkgdir)))
-pkgparentdir = $(patsubst %$(pkgname)/,%,$(pkgdir))
 
 # Define extractors for different archive suffixes
 INFLATE.bz2  = $(BZCAT)