package/libsemanage: add host-audit as a dependency of the host variant
authorAdam Duskett <Aduskett@gmail.com>
Sat, 16 Jul 2016 20:06:27 +0000 (16:06 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 16 Jul 2016 20:50:26 +0000 (22:50 +0200)
refpolicy requires host-libsemanage. host-libsemanage will fail to
compile without host-audit. This commit adds host-audit as a
requirement for host-libsemanage.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsemanage/libsemanage.mk

index a60d0186980b3e5b658095e2da914769c3dc236b..beb34ba3c074874255101275229cf315c5cc3dfc 100644 (file)
@@ -27,7 +27,7 @@ define LIBSEMANAGE_INSTALL_TARGET_CMDS
        $(MAKE) -C $(@D) $(LIBSEMANAGE_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
 endef
 
-HOST_LIBSEMANAGE_DEPENDENCIES = host-bison host-libsepol host-libselinux \
+HOST_LIBSEMANAGE_DEPENDENCIES = host-bison host-audit host-libsepol host-libselinux \
                                host-ustr host-bzip2 host-swig
 HOST_LIBSEMANAGE_MAKE_OPTS += $(HOST_CONFIGURE_OPTS) \
        SWIG_LIB="$(HOST_DIR)/usr/share/swig/$(SWIG_VERSION)/"