package/rtc-tools: new package
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 15 Jan 2019 09:32:29 +0000 (10:32 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 16 Jan 2019 09:56:25 +0000 (10:56 +0100)
This package contains a set of tools to manipulate RTC devices. They
are written and maintained by the RTC subsystem Linux kernel
maintainer, Alexandre Belloni.

Cc: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/rtc-tools/Config.in [new file with mode: 0644]
package/rtc-tools/rtc-tools.hash [new file with mode: 0644]
package/rtc-tools/rtc-tools.mk [new file with mode: 0644]

index aa1bf325cb12269db2870f2514c671027422c509..c1950bb0f46885da0fbcc35310d33ceb9b7f9c4f 100644 (file)
@@ -2130,6 +2130,7 @@ F:        package/python-serial/
 F:     package/qextserialport/
 F:     package/rpcbind/
 F:     package/rt-tests/
+F:     package/rtc-tools/
 F:     package/sam-ba/
 F:     package/scons/
 F:     package/squashfs/
index 0df9b73088b91be5ca5d931454797672c3aa1b5c..5036421a734a57d076f07c4c3bf9714c1e3ba471 100644 (file)
@@ -500,6 +500,7 @@ endmenu
        source "package/rng-tools/Config.in"
        source "package/rpi-userland/Config.in"
        source "package/rs485conf/Config.in"
+       source "package/rtc-tools/Config.in"
        source "package/rtl8188eu/Config.in"
        source "package/rtl8189fs/Config.in"
        source "package/rtl8723bs/Config.in"
diff --git a/package/rtc-tools/Config.in b/package/rtc-tools/Config.in
new file mode 100644 (file)
index 0000000..78f5c06
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RTC_TOOLS
+       bool "rtc-tools"
+       help
+         This package provide a set of user-space tools that can be
+         used to manipulate Real Time Clock Devices.
+
+         https://git.kernel.org/pub/scm/linux/kernel/git/abelloni/rtc-tools.git/
diff --git a/package/rtc-tools/rtc-tools.hash b/package/rtc-tools/rtc-tools.hash
new file mode 100644 (file)
index 0000000..81be1af
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 152d8455bae5ad672e99bb91dfbed5b8b4bd8b0325146d1cf1c4d80b6e0d8a16 rtc-tools-33ef4aa1c92b0c92a351284d93d1ac5570de9cc7.tar.gz
+sha256 7ae50a5344af14d6231aff6814632a220b3127da4099aea2c6070fd79c407c1a COPYING
diff --git a/package/rtc-tools/rtc-tools.mk b/package/rtc-tools/rtc-tools.mk
new file mode 100644 (file)
index 0000000..fa187a8
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# rtc-tools
+#
+################################################################################
+
+RTC_TOOLS_VERSION = 33ef4aa1c92b0c92a351284d93d1ac5570de9cc7
+RTC_TOOLS_SITE = git://git.kernel.org/pub/scm/linux/kernel/git/abelloni/rtc-tools.git
+RTC_TOOLS_LICENSE = GPL-2.0
+RTC_TOOLS_LICENSE_FILES = COPYING
+
+RTC_TOOLS_BINARIES = rtc rtc-sync rtc-range
+
+define RTC_TOOLS_BUILD_CMDS
+       $(foreach bin,$(RTC_TOOLS_BINARIES),\
+               $(TARGET_CC) $(TARGET_CFLAGS) -o $(@D)/$(bin) $(@D)/$(bin).c
+       )
+endef
+
+define RTC_TOOLS_INSTALL_TARGET_CMDS
+       $(foreach bin,$(RTC_TOOLS_BINARIES),\
+               $(INSTALL) -D -m 0755 $(@D)/$(bin) $(TARGET_DIR)/usr/bin/$(bin)
+       )
+endef
+
+$(eval $(generic-package))