minor changes to accomodate the config system updates
authorEric Andersen <andersen@codepoet.org>
Tue, 4 Nov 2003 13:56:00 +0000 (13:56 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 4 Nov 2003 13:56:00 +0000 (13:56 -0000)
make/uclibc.mk
sources/uClibc.config

index e6ab1652a757a635a7c8b97fc67538f8e4a6e145..2a30490f814508f29078b379a8d0c2d2e5eb1c53 100644 (file)
@@ -24,13 +24,13 @@ $(UCLIBC_DIR)/.unpacked: $(DL_DIR)/$(UCLIBC_SOURCE)
        touch $(UCLIBC_DIR)/.unpacked
 
 $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked $(BUILD_DIR)/linux/.configured
-       perl -i -p -e 's,^CROSS=.*,TARGET_ARCH=$(ARCH)\nCROSS=$(TARGET_CROSS),g' \
-               $(UCLIBC_DIR)/Rules.mak
+       perl -i -p -e 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(UCLIBC_DIR)/Rules.mak
 ifeq ($(ENABLE_LOCALE),true)
        cp $(SOURCE_DIR)/uClibc.config-locale $(UCLIBC_DIR)/.config
 else
        cp $(SOURCE_DIR)/uClibc.config $(UCLIBC_DIR)/.config
 endif
+       perl -i -p -e 's,^TARGET_[a-z].*,TARGET_$(ARCH)=y,g' $(UCLIBC_DIR)/.config
        perl -i -p -e 's,^KERNEL_SOURCE=.*,KERNEL_SOURCE=\"$(LINUX_DIR)\",g' \
                $(UCLIBC_DIR)/.config
        perl -i -p -e 's,^RUNTIME_PREFIX=.*,RUNTIME_PREFIX=\"$(STAGING_DIR)\",g' \
index d858814f44c7b222244b10489dbf616639851171..f023406f66c74fb54b0c4cad8983d748062ab4c5 100644 (file)
@@ -1,20 +1,20 @@
 #
 # Automatically generated make config: don't edit
 #
-# TARGET_ALPHA is not set
-# TARGET_ARM is not set
-# TARGET_CRIS is not set
-# TARGET_E1 is not set
-# TARGET_H8300 is not set
-TARGET_I386=y
-# TARGET_I960 is not set
-# TARGET_M68K is not set
-# TARGET_MICROBLAZE is not set
-# TARGET_MIPS is not set
-# TARGET_POWERPC is not set
-# TARGET_SH is not set
-# TARGET_SPARC is not set
-# TARGET_V850 is not set
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_cris is not set
+# TARGET_e1 is not set
+# TARGET_h8300 is not set
+TARGET_i386=y
+# TARGET_i960 is not set
+# TARGET_m68k is not set
+# TARGET_microblaze is not set
+# TARGET_mips is not set
+# TARGET_powerpc is not set
+# TARGET_sh is not set
+# TARGET_sparc is not set
+# TARGET_v850 is not set
 
 #
 # Target Architecture Features and Options