package/rauc: add a WantedBy section to the systemd unit file
authorJérémy Rosen <jeremy.rosen@smile.fr>
Mon, 16 Dec 2019 10:30:51 +0000 (11:30 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Dec 2019 17:33:22 +0000 (18:33 +0100)
upstream-provided service has no WantedBy, which means that rauc won't
be enabled by default

Add a WantedBy instead of manually creating the symlink so the user can
enable/disable the unit properly

Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr>
[yann.morin.1998@free.fr:
  - split long line
  - no need for continued line (no use for ';\' )
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/rauc/rauc.mk

index f3434e9c9a6fd66fdf8c30a17f47bcf1b65e67c4..5a208e07aeb9cf8275516b27880000ec94d3ae4d 100644 (file)
@@ -31,9 +31,9 @@ RAUC_DEPENDENCIES += systemd
 endif
 
 define RAUC_INSTALL_INIT_SYSTEMD
-       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -sf ../../../../lib/systemd/system/rauc.service \
-               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/rauc.service
+       mkdir $(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d
+       printf '[Install]\nWantedBy=multi-user.target\n' \
+               >$(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d/buildroot-enable.conf
 endef
 
 HOST_RAUC_DEPENDENCIES = \