directfb: added directfb tests installation option
authorLionel Landwerlin <llandwerlin@gmail.com>
Fri, 30 Apr 2010 00:58:47 +0000 (02:58 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 May 2010 07:26:37 +0000 (09:26 +0200)
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/directfb/Config.in
package/directfb/directfb.mk

index 7c41cdf21224e74fbeb84d87476fd5d0107d2e28..5e81b7ede8b03132bcc6f6125eead9f4d1c558e2 100644 (file)
@@ -98,4 +98,7 @@ config BR2_PACKAGE_DIRECTB_DITHER_RGB16
          Enable dithering when loading images to RGB16 surfaces.
          This increases the data section by 64 KBytes.
 
+config BR2_PACKAGE_DIRECTB_TESTS
+       bool "build directfb tests"
+
 endif # BR2_PACKAGE_DIRECTFB
index c5d9c2b587cc52b819ce1e5ee0b9962e144e5703..ccb0c5aa9a11dcd381335996514d07473cc473aa 100644 (file)
@@ -121,6 +121,12 @@ else
 DIRECTFB_DITHER_RGB16:=--with-dither-rgb16=none
 endif
 
+ifeq ($(BR2_PACKAGE_DIRECTB_TESTS),y)
+DIRECTFB_TESTS:=--with-tests
+else
+DIRECTFB_TESTS:=
+endif
+
 DIRECTFB_CONF_OPT = \
        --localstatedir=/var \
        --with-gfxdrivers=$(DIRECTFB_GFX) \
@@ -146,7 +152,8 @@ DIRECTFB_CONF_OPT = \
        --disable-sdl \
        --disable-vnc \
        --disable-video4linux \
-       --disable-video4linux2
+       --disable-video4linux2 \
+       $(DIRECTFB_TESTS)
 
 DIRECTFB_DEPENDENCIES = $(DIRECTFB_DEP) freetype $(DIRECTFB_FUSION)