use the correct strip tool for host and target binaries
authorEric Andersen <andersen@codepoet.org>
Wed, 22 Jan 2003 11:11:35 +0000 (11:11 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 22 Jan 2003 11:11:35 +0000 (11:11 -0000)
make/uclibc_toolchain.mk

index 0b2c597beb125adc93dba918b28f4e9a74feb601..ee65c7ff46f27de8433a6c1dfd07e4814b0d7ce5 100644 (file)
@@ -442,7 +442,9 @@ $(BUILD_DIR)/.shuffled: $(GCC_BUILD_DIR2)/.fixedup
        touch $(BUILD_DIR)/.shuffled
 
 $(BUILD_DIR)/.stripped: $(BUILD_DIR)/.shuffled
-       -$(STRIP) --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+       # Strip the host binaries
+       -strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+       # Strip the target shared libs
        -$(STRIP) --strip-unneeded -R .note -R .comment $(STAGING_DIR)/lib/*.so*;
        touch $(BUILD_DIR)/.stripped