Patch from "Kevin P. Fleming" <kpfleming@backtobasicsmgmt.com>.
authorManuel Novoa III <mjn3@codepoet.org>
Thu, 11 Mar 2004 08:03:44 +0000 (08:03 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Thu, 11 Mar 2004 08:03:44 +0000 (08:03 -0000)
Provides a script for yacc in terms of bison instead of a symlink.

make/bison.mk
sources/yacc [new file with mode: 0755]

index 71a6d7788fd03696f325e5277fe3d7d5090d2f6f..89c9b916cc8390867a345a17257c16bb5c17f5ef 100644 (file)
@@ -49,7 +49,7 @@ $(TARGET_DIR)/$(BISON_TARGET_BINARY): $(BISON_DIR)/$(BISON_BINARY)
        $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) install
        rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
                $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
-       (cd $(TARGET_DIR)/usr/bin; ln -fs bison yacc)
+       cp -a $(SOURCE_DIR)/yacc $(TARGET_DIR)/usr/bin/yacc
 
 bison: uclibc $(TARGET_DIR)/$(BISON_TARGET_BINARY)
 
diff --git a/sources/yacc b/sources/yacc
new file mode 100755 (executable)
index 0000000..aed120e
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/bison -y "$@"